Circles are not exported when saving in DXF file format

Bug #1489320 reported by Yann Papouin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Fix Released
Wishlist
Alvin Penner

Bug Description

Since release 0.91, circles are no more exported via the python script in DXF.

By comparing the same SVG content in 0.48 and 0.91, it looks like that the circle path definition is no more stored in the SVG file since 0.91.

It could explain why the python script is no more able to export circles.

Tags: dxf exporting
Revision history for this message
Yann Papouin (yann-papouin) wrote :
Revision history for this message
Yann Papouin (yann-papouin) wrote :
su_v (suv-lp)
tags: added: dxf exporting
Revision history for this message
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91 r13725 and 0.91+devel r14325 on OS X 10.7.5.

Would be nice to have support for native <circle> and <ellipse> SVG shapes (new in >= 0.91) - for now, a workaround exists (convert to path before exporting to DXF).

Changed in inkscape:
importance: Undecided → Wishlist
milestone: none → 0.92
status: New → Confirmed
Revision history for this message
Alvin Penner (apenner) wrote :

attached is a proposed fix for this bug. This implements support for circle and ellipse elements, which had previously been represented as paths. This code can be tested by copying the file to the Inkscape\share\extensions\ directory. In Inkscape 0.91 you will also need to copy the new version of the dxf_outlines.inx file from the repository:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/files/head:/share/extensions/

If testing under Inkscape 0.91 you may detect a slight scaling change due to the fact that the new code uses a default 96 dpi for scale conversions while Inkscape 0.91 uses a default 90 dpi.

Revision history for this message
Alvin Penner (apenner) wrote :

fix committed to rev 14338

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Alvin Penner (apenner)
su_v (suv-lp)
tags: added: backport-proposed
Revision history for this message
Yann Papouin (yann-papouin) wrote :

Thank you for the fix.

Note that the dxf_outlines.inx file is identical to the 0.91 one (About that, I don't really understand the relation between the actual dxf_outlines.inx content and the py file: pstoedit ? ps2dxf.sh ?)

Revision history for this message
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13810.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico)
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers