Wrong stroke-dasharray processing with trailing spaces

Bug #1485197 reported by RazrFalcon on 2015-08-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Tavmjong Bah

Bug Description

stroke-dasharray="5 5 "
and
stroke-dasharray="5 5"
Renders differently, but should look exactly the same.

=====
Inkscape 0.91 r13725
Gentoo Linux

RazrFalcon (razrfalcon) wrote :
su_v (suv-lp) wrote :

Please always include information about OS/platform and Inkscape version in the bug description, thank you.

tags: added: regression styles
su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.48.5 r10040
- reproduced with Inkscape 0.81 r13725 and 0.91+devel r14302

Based on tests with archived builds:
- not reproduced with 0.91+devel rev <= 13134,
- reproduced with 0.91+devel rev >= 13135;
this seems to be a side-effect of the refactoring in
Revision 13135: Change stroke-dasharray and stroke-dashoffset handling to match other properties.
Split style.h into more manageable size files.
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13135

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.92
status: New → Confirmed
RazrFalcon (razrfalcon) wrote :

Forget about enviroment.

Inkscape 0.91 r13725
Gentoo Linux

su_v (suv-lp) on 2015-08-15
description: updated
jazzynico (jazzynico) wrote :

Reproduced on Windows XP (32-bit), Inkscape 0.91 and trunk rev. 14948.

Changed in inkscape:
status: Confirmed → Triaged
tags: added: svg
jazzynico (jazzynico) wrote :

@Tav, could you please take a look?

jazzynico (jazzynico) wrote :

Apparently the stroke with the trailing space is seen as 5,5,0.

Tavmjong Bah (tavmjong-free) wrote :

Only affects stroke-dasharray as attribute. Presumably, libcroco is stripping of trailing zero.

Tavmjong Bah (tavmjong-free) wrote :

Fixed in r14950.

Also fixed reading numbers of the form .9 (no leading digits).

jazzynico (jazzynico) wrote :

Fix confirmed on Windows XP, with r14950. Thanks Tav!

Changed in inkscape:
assignee: nobody → Tavmjong Bah (tavmjong-free)
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments