DXF import scrambled

Bug #1483807 reported by Phil on 2015-08-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

Inkscape 0.91
Windows 7 Pro

I'm finding my DXF files are scrambled, per the image below when I try to import them from NX 9.

http://postimg.org/image/hur9zwh8l

I've tried:
  -Exporting as different DXF versions (2000-2013).
  -Varying options in the DXF export prompt (hiding / keeping double lines)...

The dxf files work when opening them in other CAD programs. Can post DXF files if needed.

Phil (pjohnson797) on 2015-08-11
description: updated
description: updated
description: updated
su_v (suv-lp) wrote :

On 2015-08-11 17:59 (+0200), Phil wrote:
> Can post DXF files if needed.

Yes, please attach the original DXF files to the bug report - without those files it is not possible to further investigate the reported issue. Please also attach the Inkscape SVG file(s) you saved of the imported DXF files, and provide details about the DXF import options used in Inkscape.

Changed in inkscape:
status: New → Incomplete
tags: added: dxf importing
Phil (pjohnson797) wrote :

Thanks! I've attached DXF.

Phil (pjohnson797) wrote :

...SVG after import.

Phil (pjohnson797) wrote :

...screenshot of import settings.

su_v (suv-lp) on 2015-08-11
Changed in inkscape:
status: Incomplete → New
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48.5, 0.91 r13725 and 0.91+devel r14285 on OS X 10.7.5.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Alvin Penner (apenner) wrote :

also reproduced on QCad 3.9.1.0, attached is the image obtained in QCad. The file appears to contain some features which are quite new. Based on past experience, if QCad does not succeed then Inkscape will not succeed either, since QCad is more uptodate and more complete than the Inkscape import. The dxf file version is AC1027, so I assume that this actually came from AutoCad not some other software.

su_v (suv-lp) wrote :

Not reproduced with QCad 3.9.7.0 and Draftsight 2015.3.0.3019 on OS X 10.7.5.

Alvin Penner (apenner) wrote :

I just upgraded to QCad 3.9.8 on Windows XP, and now the file Plate.dxf loads correctly into QCad.

With QCad there is a workaround available. Choose the menu option File->Quick SVG Export and save it as svg. This produces the attached file Plate.svg which looks okay.

P.S. in order for this import to work, you will need to keep the add-on called 'QCAD Pro'. I did one test where I removed this add-on and the original dxf file did not load correctly.

Phil (pjohnson797) wrote :

Thanks! Using QCAD workaround. I've noticed this issue with other DXF files as well (example attached).

Alvin Penner (apenner) wrote :

attached is a proposed fix for this bug. This implements a new dxf attribute called extrude, which can reflect an object about the y axis. This can be tested by copying the file to the Inkscape\share\extensions\ directory. In Inkscape 0.91 you will also need to copy the new version of the dxf_input.inx file from the repository:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/files/head:/share/extensions/

If testing under Inkscape 0.91 you may detect a slight scaling change due to the fact that the new code uses a default 96 dpi for scale conversions while Inkscape 0.91 uses a default 90 dpi.

Alvin Penner (apenner) wrote :

fix committed to rev 14312

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Alvin Penner (apenner)
su_v (suv-lp) on 2015-08-20
Changed in inkscape:
milestone: none → 0.92
su_v (suv-lp) on 2015-09-30
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13834.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers