Duplicate closing node on node path operation

Bug #1482907 reported by Jabiertxof on 2015-08-08
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

NEW BUG DESCRIPTION::
On a closed BSpline path, last node became duplicated when operating with other paths nodes. Attached example of the problem in SVG.

Steps to reproduce ONE:
1) open bspline.extranode.svg in current trunk
2) Select the big shape
--> tooltip show 38 nodes
3) Move it
--> Tooltip show 39 nodes

Steps to reproduce TWO:
1) open bspline.extranode.svg in current trunk
2) Move the node marked with the black circle
--> sometimes the node marked with the red circle changes
3) Unselect the path and select it again
--> the node marked with red circle is duplicated

~suv speculates it could be related to bugs:
Bug #515237: "Rotate shape adds node"
Bug #614628: ""Join selected nodes" adds an extraneous node when joining near-duplicate nodes"

=====
Inkscape version: 0.91+devel r14828, r14301

su_v (suv-lp) on 2015-08-08
tags: added: node-editing
removed: node tool
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.91 r13725 and 0.91+devel r14283 on OS X 10.7.5 (tested with default (new) prefs).

--
<off-topic>
Please don't forget to always include information about OS/platform and used Inkscape version / build revno to new bug reports, thank you.
</off-topic>

su_v (suv-lp) on 2015-08-08
description: updated
Jabiertxof (jabiertxof) wrote :

Thanks for your review and time, I also coulden't reproduce.

Changed in inkscape:
status: New → Invalid
su_v (suv-lp) wrote :

JFTR - not reproduced on Ubuntu 14.04.2 LTS (VM 64bit, host: OS X 10.7.5) either, tested with Inkscape 0.91 r13725 and 0.91+devel r14283 (both from inkscape.dev PPAs).

Jabiertxof (jabiertxof) on 2015-08-14
Changed in inkscape:
status: Invalid → New
description: updated
description: updated
description: updated
Jabiertxof (jabiertxof) wrote :

Here are the bug example of the main bug

description: updated
description: updated
su_v (suv-lp) on 2015-08-14
description: updated
su_v (suv-lp) wrote :

Testing steps for new test case 'bspline.extranode.svg' with r14302 on OS X 10.7.5:
ONE (node count changes when moving a path): not reproduced
TWO (closing node duplicates after node-editing the path elsewhere): reproduced

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
su_v (suv-lp) wrote :

On 2015-08-14 20:13 (+0200), ~suv wrote:
> ONE (node count changes when moving a path): not reproduced

On the other hand, the node count displayed by the select tool does change to 39 if I rotate the path (similar to bug #515237), instead of moving it.

su_v (suv-lp) wrote :

Another observation with regard to node count displayed in the status bar by the select tool, before and after moving the path (r14302 on OS X 10.7.5):

If I lower the numeric precision to 7 and relaunch inkscape with the test case:
- initial node count: 37 nodes
- node count after first move: 38 nodes
- node count after third and later moves: 39

Reverting numeric precision again to default '8', relaunching inkscape: node count (38) again stays unchanged on move, and only changes on rotation (from 38 to 39).

Discrete Games (discretegames) wrote :

I can reproduce this bug in Windows 10, Inkscape 0.92.3 (2405546, 2018-03-11).

In fact it happens to me all the time when working with closed BSpline shapes. I made another bug report recently that I now realize is a duplicate of this one: https://bugs.launchpad.net/inkscape/+bug/1762093

If this is a precision issue would using much larger shapes fix (or at least avoid) it? I tried scaling up the shape in the provided svg and can no longer reproduce the bug. For now this appears to be a promising workaround!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers