Crash when renaming a guideline label in a new session

Bug #1469514 reported by Mush Man on 2015-06-28
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Critical
jazzynico

Bug Description

When a user renames a guideline's label in a new session, Inkscape will crash. The behaviour is reproducible.

1. Create a guideline and label it
2. Open a new session by opening the file again from Inkscape or the file system
3. Change the label of the guideline made last session and press OK

This does not occur if the guideline from the last session had an empty label. A crash is not encountered when changing guideline labels in the same session.

I have only tested with 0.91 Stable on Windows 8.1 x64.

Related branches

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91 r13725 and 0.91+devel r14220 on OS X 10.7.5.

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
summary: - Windows: Crash when renaming a guideline label in a new session
+ Crash when renaming a guideline label in a new session
su_v (suv-lp) wrote :

Backtrace with 0.91+devel r14212 (debug build)

su_v (suv-lp) wrote :

Based on tests with archived builds (on OS X 10.7.5):
- not reproduced with Inkscape 0.91+devel r13226, r13227
- reproduced with 0.91+devel r13228;
this crash seems to be a side-effect of the changes in revision 13228 for bug #1299185:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13228

tags: added: crash
removed: win64
Mush Man (mushman) on 2015-06-28
description: updated
description: updated
description: updated
description: updated
jazzynico (jazzynico) wrote :

Also reproduced on Windows XP (32bit), Inkscape trunk rev. 14221.

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) wrote :

Raising bug importance (no emergency save file is created -> loss of data).

tags: added: regression
Changed in inkscape:
importance: High → Critical
milestone: none → 0.92
jazzynico (jazzynico) wrote :

Related report: Bug #1498444 "Guides flicker under the mouse after changing the label of any guide".

It would be interesting to test the patch from Bug #1498444, comment #11 on Windows or OS X.

jazzynico (jazzynico) wrote :

Note that the crash doesn't occur consistently on Windows XP (32bit), official devlibs.

su_v (suv-lp) wrote :

On 2015-10-15 07:21 (+0200), jazzynico wrote:
> It would be interesting to test the patch from Bug #1498444, comment
> #11 on Windows or OS X.

Proposed fix from bug #1498444 tested successfully with 0.91+devel r14415 on OS X 10.7.5 (diff attached, still pending review, see bug #1498444): no crash when editing a guide label in the next session.

jazzynico (jazzynico) wrote :

@Martin - It seems the cause of the crash is the same as in bug #1498444. Could you please confirm that the guide's label is already freed elsewhere and that removing the extra "free" is the best fix?

jazzynico (jazzynico) wrote :

Patch applied to the trunk rev. 14426.

Feel free to revert if there's a more elegant or efficient fix.

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
status: Triaged → Fix Committed
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13846.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
LittleBigBrain (braingateway) wrote :

does not crash, but the guideline will disappear. 0.91.0+47

jazzynico (jazzynico) on 2017-01-22
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers