crash when opening file

Bug #1468396 reported by mray on 2015-06-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Jabiertxof

Bug Description

Inkscape 0.91+devel r, 64bit ubuntu

crashes when opening the attached file.
Inkscape suddenly crashed on me (hence the file name with date).
Interestingly Inkscape already crashes when trying to display the preview in the file manager.

mray (mrayyyy) wrote :
su_v (suv-lp) on 2015-06-24
tags: added: crash livepatheffects
Alvin Penner (apenner) wrote :

reproduced on Windows XP, Inkscape 0.91+devel r14202 (Jun 17 2015)

backtrace attached:

Program received signal SIGSEGV, Segmentation fault.
0x0083dd5a in Inkscape::LivePathEffect::FilletChamferPointArrayParam::get_times
()
(gdb) bt
#0 0x0083dd5a in Inkscape::LivePathEffect::FilletChamferPointArrayParam::get_times ()
#1 0x77c2c3ce in msvcrt!free () from C:\WINDOWS\system32\msvcrt.dll
#2 0x0023e224 in ?? ()
#3 0x0023e5f8 in ?? ()
#4 0x00000000 in ?? ()
(gdb) c
Continuing.

Program received signal SIGSEGV, Segmentation fault.
0x0083dd5a in Inkscape::LivePathEffect::FilletChamferPointArrayParam::get_times
()
(gdb) c
Continuing.

Program exited with code 030000000005.

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91+devel r14212 on OS X 10.7.5 (full backtrace attached).

The trigger seems to be a partial definition of a path effect without any parameter attributes:

    <inkscape:path-effect
       effect="fillet-chamfer"
       id="path-effect35835" />

applied to a path in the group last added to the current layer in the drawing (id="path35831").

@jabiertxof - any chance you could take a look how this crash could be avoided? Could such documents be edited with the path effect in question disabled?

Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: Confirmed → Triaged
su_v (suv-lp) wrote :

@mray - attached is an edited version of your file with the path effect definition deleted: it opens ok again in current trunk, but the path effect used on the path in the last group (select with 'Shift+TAB' after opening the drawing) is lost.

I don't know what steps could have caused that partial definition of the path effect.

I try to do this sunday.
Hi, Jabier.

El jue, 25-06-2015 a las 00:16 +0000, ~suv escribió:
> Reproduced with Inkscape 0.91+devel r14212 on OS X 10.7.5 (full
> backtrace attached).
>
> The trigger seems to be a partial definition of a path effect without
> any parameter attributes:
>
> <inkscape:path-effect
> effect="fillet-chamfer"
> id="path-effect35835" />
>
> applied to a path in the group last added to the current layer in the
> drawing (id="path35831").
>
> @jabiertxof - any chance you could take a look how this crash could
> be
> avoided? Could such documents be edited with the path effect in
> question
> disabled?
>
> ** Attachment added: "1468396-bt-full-r14212-debug-osx-x11-64bit.txt"
> https://bugs.launchpad.net/inkscape/+bug/1468396/+attachment/44201
> 90/+files/1468396-bt-full-r14212-debug-osx-x11-64bit.txt
>
> ** Changed in: inkscape
> Importance: Undecided => High
>
> ** Changed in: inkscape
> Status: Confirmed => Triaged
>
> ** Changed in: inkscape
> Milestone: None => 0.92
>

Jabiertxof (jabiertxof) on 2015-06-25
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
Jabiertxof (jabiertxof) on 2015-06-25
Changed in inkscape:
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
su_v (suv-lp) on 2015-06-25
Changed in inkscape:
milestone: 0.92 → none
Jabiertxof (jabiertxof) wrote :

Finaly get some time today. @mray I see you use intensive fillet chamfer. Take care because fillet chamfer is now full rewrited pending to merge and not compatible with current LPE, By the other side is too much more stable!

su_v (suv-lp) wrote :

@Jabiertxof - Inkscape 0.91+devel r14217 still crashes, just a bit later, when selecting the path with the node tool.

Steps to reproduce:
1) launch r14217
2) open 'logo16.svg.2015_06_23_00_26_27.1.svg'
3) use 'Shift+TAB' to select the last group
4) 'Ctrl+Enter', 'TAB' (selects path)
5) switch to node tool
--> crash:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x0000000000000000
0x00000001003abf1f in Inkscape::LivePathEffect::FilletChamferPointArrayParam::recalculate_knots ()
(gdb) bt
#0 0x00000001003abf1f in Inkscape::LivePathEffect::FilletChamferPointArrayParam::recalculate_knots ()
#1 0x00000001003b0dbe in Inkscape::LivePathEffect::FilletChamferPointArrayParam::addKnotHolderEntities ()
#2 0x0000000100301822 in Inkscape::LivePathEffect::Effect::addHandles ()
#3 0x0000000100455864 in Inkscape::UI::createKnotHolder ()
#4 0x000000010045d9b4 in Inkscape::UI::ShapeEditor::set_item ()
#5 0x00000001006605dc in Inkscape::UI::Tools::NodeTool::selection_changed ()
#6 0x00000001006615a9 in Inkscape::UI::Tools::NodeTool::set ()
#7 0x0000000100683d33 in Inkscape::UI::Tools::sp_event_context_read ()
#8 0x000000010065ffd4 in Inkscape::UI::Tools::NodeTool::setup ()
#9 0x000000010002083c in SPDesktop::set_event_context2 ()
#10 0x000000010045e082 in tools_switch ()

Jabiertxof (jabiertxof) wrote :

Thanks, su_v! I just fix it.

mray (mrayyyy) wrote :

Thanks everybody!

I truly admire the work you put into this.
@~suv: thanks for providing a repaired file, I can open it again now.
@Jabier: thanks for the info on the fillet/camfer LPE , looking forward to the rewrite.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers