Powerstroke dialog does not handle non-english number formats

Bug #1457172 reported by Ben Scholzen 'DASPRiD' on 2015-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Ben Scholzen 'DASPRiD'

Bug Description

When the system is set to use a number format which does not use a period as decimal separator, but e.g. a comma, the number is not correctly parsed when applying the values. Steps to reproduce:

- Set system's locale to e.g. German
- Create a path
- Apply powerstroke LPE to it
- Shift-click on the middle pink powerstoke node
- You should see position of "0,5"; click "Move"
- The node is moved to "0" position, instead of keeping it at "0.5"

This affects trunk only.

Related branches

su_v (suv-lp) on 2015-05-20
tags: added: i18n livepatheffects ui
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91+devel r14164 on OS X 10.7.5 (using de_DE.UTF-8 as locale).

Not reproduced with 0.91 - there is no GUI to adjust the position of a powerstroke knot numerically in the stable release branch (IIRC this feature was ported from ponyscape, and merged into trunk after the stable release branch was created).

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.92
status: New → Confirmed
description: updated
su_v (suv-lp) wrote :

Fix (diff from branch) tested successfully with Inkscape 0.91+devel r14172 (GTK2 build only) on OS X 10.7.5.

Changed in inkscape:
assignee: nobody → Ben Scholzen 'DASPRiD' (dasprid)
status: Confirmed → In Progress
su_v (suv-lp) wrote :

Merged into trunk in rev 14173.

@dasprid - thanks a lot!

Changed in inkscape:
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers