Trace Bitmap: 'Multiscan > Brightness steps' produces mostly black result (>= 0.91)

Bug #1456387 reported by su_v on 2015-05-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

Bitmap tracing with 'Multiple scans > Brightness steps' produces mostly black result instead of the expected greyscale image with Inkscape 0.91 and later.

Steps to reproduce:
1) launch 0.91 or trunk
2) import bitmap image (import settings don't matter)
3) open 'Path > Trace Bitmap'
4) Choose 'Multiple scans > Brightness steps'
   (keep default for all other settings)
5) Press 'OK' to create the tracing

Expected result:
A group of 8 paths with varied levels of grey as fill color is inserted onto the canvas.

Actual result:
A group of 8 paths with 'unset' fill color (renders black) is inserted onto the canvas

Reproduced with Inkscape 0.91 r13725 and 0.91+devel r14162 on OS X 10.7.5.

Based on tests with archived builds (on OS X 10.7.5), this regression seems to have been introduced quite a while ago:
- not reproduced with Inkscape 0.48.5
- not reproduced with r10325, r10326 (right before and after the merge of the cairo renderer branch)
- reproduced with r10588, r10589 (right before and after the removal of libnr)
- reproduced with any later build (0.91, and current trunk)

The cause seems related to changes between r10327 and 10588 (unfortunately no archived builds in-between available).

su_v (suv-lp) wrote :
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk rev. 14165 and rev. 10568 (sorry, older archive available).

Changed in inkscape:
importance: Undecided → Medium
status: New → Triaged
jazzynico (jazzynico) wrote :

..not available.

And, of course, not reproduced with 0.48.5.

su_v (suv-lp) wrote :

Digging out old archived builds on Mac OS X 10.5.8:
- not reproduced with rev <= 10506,
- reproduced with rev >= 10508;
this regression seems to have been exposed with the changes of rev 10507/10508:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/10508

r10507: Cleaning up trace methods to aid fixing color inversion.
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/10507

r10508: Reverse color order in tracing support function to match reversal of colors in GdkPixmaps used. Fixes bug #815596.
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/10508

jazzynico (jazzynico) wrote :

Patch attached.

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
status: Triaged → In Progress
tags: added: backport-proposed
su_v (suv-lp) wrote :

Patch tested successfully with r14202 on OS X 10.7.5.

jazzynico (jazzynico) wrote :

Thanks for testing!
Fixed in the trunk, revision 14209.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13799.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-22
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers