A change of the "Image quality" for an embedded/linked image can't be saved in some circumstances.

Bug #1450875 reported by rickmastfan67 on 2015-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

Inkscape 0.91 r13725 x64 (MSI)
Windows 7 SP1 x64

Steps to reproduce the problem: (You can skip steps #1-#6 if you already have a file with a PNG/JPG type image saved in it.)
1. Start with a fresh profile. (this isn't really necessary, as I can duplicate it with my normal profile, but as a safety net)
2. Find an image you want to import into Inkscape via Windows Explorer.
3. Now, right click on the image > Open with > Inkscape.
4. When the 'import' screen shows up, Select the following options: 'Link' ; 'From file' ; 'None (auto)'
5. Once the Inkscape window loads with the image you selected, save it as an SVG file (doesn't matter where).
6. Once the SVG is saved, open the SVG file in a text editor (keep Inkscape open, but minimized) and notice that there is no 'style' info for the image.
7. Now, go back into Inkscape and right click on the image and then go into 'Object Properties'.
8. Now, go to the 'Image Rendering' and change it to either of the other two options (doesn't matter as long as you don't leave it on 'auto' or whatever setting it was already set as).
9. Hit the 'Set' button to lock in the change.
10. Try to save the image again.

What happens:
Inkscape refuses to resave the image. It thinks nothing was changed, even though you did change how the image was suppose to be rendered.

What should happen:
Inkscape should save the SVG file without objecting since you did change something in it.

Work around(s):
1. File > Save As --- that allows the change in the 'Image Rendering' to be saved into your SVG file.
2. Do something else in the file that is registered as a 'change'.

=

This also happens if the image is already saved on a layer. So, the '(root)' layer isn't the cause here.

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk rev. 14142.

Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
tags: added: bitmap preferences saving
jazzynico (jazzynico) on 2015-05-11
Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
milestone: none → 0.92
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Patch tested on Windows XP, Inkscape trunk rev. 14142.

Can be backported to 0.91.x, but with a new untranslated string.

jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 14144.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

@JazzyNico - re "new untranslated string", can I backport as is, or does the diff have to be changed (without '_()')?

tags: added: backport-proposed
jazzynico (jazzynico) wrote :

@suv - you can backport as is. The _() means that the string *can* be translated, be will show untranslated if the PO files are not updated.

su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13837.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-22
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers