[trunk] Perspective/Envelope LPE fails to recognise capitalised attribute names

Bug #1443039 reported by Parcly Taxel on 2015-04-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jabiertxof

Bug Description

Opening or previewing (in the open or save dialogues) the attached file in inkscape-trunk r14055 on Trisquel 7.0 (based on Trusty) leads to a crash. However, if lines 32 and 33 are changed in a text editor so that their last four attributes are in lowercase (i.e. up_left_point, up_right_point, down_left_point, down_right_point), the problem disappears.

I am convinced that the bug arose from r14052, which failed to ensure compatibility with older files using the Perspective/Envelope LPE with the capitalised attribute names.

su_v (suv-lp) wrote :

On OS X 10.7.5: crash on load
- not reproduced with 0.91+devel rev 14048
- reproduced with 0.91+devel rev 14055

tags: added: regression
summary: - Perspective/Envelope LPE fails to recognise capitalised attribute names
+ [trunk] Perspective/Envelope LPE fails to recognise capitalised
+ attribute names
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: New → Confirmed
su_v (suv-lp) wrote :

Crash seems related to changing the case in names of attributes stored in the patheffect definition in the <defs> section. Since this specific patheffect was never in a stable release version, it seems ok to me to commit breaking changes to such a "work-in-progress" path effect to recent trunk which are not fully backwards-compatible to earlier trunk builds. Path effects are not (or can't) be finalized with their initial first commit (changes are allowed as long as they have not been part of a stable release).

Changed in inkscape:
importance: High → Medium
milestone: 0.92 → none
su_v (suv-lp) wrote :

@Jabiertxof - could the crash be avoided without reverting the refactoring of the Perspective/Envelope patheffect - e.g. by disabling the effect if stored with old or incompatible attribute names (as happens with other unsupported path effects ("Unknown LPE type specified, LPE stack effectively disabled"))?

Jabiertxof (jabiertxof) wrote :

Thanks parclytaxel for fill the bug!

Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
status: Confirmed → Fix Committed
Jabiertxof (jabiertxof) wrote :

The fix reset your current LPE :( but you can reaply it with no crash.

su_v (suv-lp) on 2015-04-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers