'image' element opacity works differently in group

Bug #1434122 reported by RazrFalcon on 2015-03-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Mc

Bug Description

Image element opacity works differently in group and on image directly.
Simple example:
<g opacity="0.5"><image/> </g>
and
<g><image opacity="0.5"/> </g>
gives us different images.

Tested on Inkscape 0.91.

RazrFalcon (razrfalcon) wrote :
RazrFalcon (razrfalcon) wrote :
su_v (suv-lp) on 2015-03-19
tags: added: bitmap regression renderer-cairo
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.92
status: New → Confirmed
su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.48.5
- reproduced with Inkscape 0.91 r13725 and 0.91+devel r14016

Based on tests with archived builds:
- not reproduced with 0.91+devel rev <= 12597,
- reproduced with 0.91+devel rev >= 12600;
this regression was possibly introduced with the changes in r12599 (for bug #804162):
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/12600
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12599

--
replaces comment #3 (hidden) to fix typo in revision number

Changed in inkscape:
importance: Medium → High
su_v (suv-lp) wrote :

Related earlier reports (AFAICT this issue existed in 0.47 and earlier too, but at the time was fixed for the initial release of Inkscape 0.48):
* Bug #284147 Imported bitmap objects rendered with wrong <100% Master Opacity
* Bug #389130 Inkscape PNG transparency display appearance does not match export and other standard applications

The earlier fix (tracked in bug #284147) was committed in
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/9429

Mc (mc...) wrote :

committed in r14306 with my smallest diff up to now :

- dc.paint(_opacity);
+ dc.paint(1);

// something else is probably already in charge of computing opacity, elsewhere, so it was doubly transparent

Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Confirmed → Fix Committed
su_v (suv-lp) on 2015-08-17
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13808.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers