Inkscape crash on select all same type objects

Bug #1429127 reported by Clon on 2015-03-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Mc
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

Inkscape crashed when "select all same type objects" (alt+shift+A) is used without selected object.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: inkscape 0.91-3ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic i686
ApportVersion: 2.16.2-0ubuntu1
Architecture: i386
CrashCounter: 1
CurrentDesktop: LXDE
Date: Fri Mar 6 13:51:29 2015
ExecutablePath: /usr/bin/inkscape
InstallationDate: Installed on 2013-03-16 (720 days ago)
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
ProcCmdline: inkscape
SegvAnalysis: Skipped: missing required field "Disassembly"
Signal: 11
SourcePackage: inkscape
UpgradeStatus: Upgraded to vivid on 2015-02-27 (6 days ago)
UserGroups: adm audio cdrom dialout dip disk fax floppy fuse lpadmin netdev plugdev sambashare scanner sudo tape video

Clon (fillip1) wrote :

StacktraceTop:
 magazine_chain_pop_head (magazine_chunks=<optimized out>) at /build/buildd/glib2.0-2.43.91/./glib/gslice.c:539
 thread_memory_magazine1_alloc (tmem=<optimized out>, ix=<optimized out>) at /build/buildd/glib2.0-2.43.91/./glib/gslice.c:842
 g_slice_alloc (mem_size=8) at /build/buildd/glib2.0-2.43.91/./glib/gslice.c:998
 g_slist_prepend (list=0x98305d0, data=0xadc64e0) at /build/buildd/glib2.0-2.43.91/./glib/gslist.c:254
 add_widget_to_closure (widget=widget@entry=0xadc64e0, mode=mode@entry=GTK_SIZE_GROUP_HORIZONTAL, groups=0xbfd3af18, widgets=0xbfd3af14) at /build/buildd/gtk+2.0-2.24.27/gtk/gtksizegroup.c:136

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Clon (fillip1) on 2015-03-17
information type: Private → Public
Alvin Penner (apenner) wrote :

- confirmed on Windows 7, 32 bit, Inkscape 0.91 r13725 (Jan 30 2015)
- with no object selected, click on the menu item Edit->Select Same->Object Type or Edit->Select Same->Stroke Style
- as far as I can tell, the crash does not occur if no object has ever been created. It seems to occur after creating objects and then de-selecting them. Also the crash message is not consistent. Below are four different crash messages obtained from 4 separate crashes.

(inkscape.exe:2284): GLib-CRITICAL **: g_string_free: assertion `string != NULL' failed

(inkscape.exe:4792): Pango-CRITICAL **: _pango_engine_shape_covers: assertion `PANGO_IS_FONT (font)' failed

(inkscape.exe:4156): GLib-GObject-WARNING **: invalid cast from `(null)' to `PangoFont'

(inkscape.exe:2268): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 17: Element 'markup' was closed, but the currently open element is ''

Changed in inkscape:
status: New → Confirmed
Alvin Penner (apenner) wrote :

crash not reproduced on Windows XP, Inkscape 0.91+devel r14129 (May 8 2015)

su_v (suv-lp) wrote :

On OS X 10.7.5:
- reproduced with Inkscape 0.91 r13725
- not reproduced with Inkscape 0.91+devel r14151

tags: added: crash selection
Changed in inkscape:
milestone: none → 0.92
status: Confirmed → Fix Committed
importance: Undecided → High
su_v (suv-lp) wrote :

Based on tests with archived trunk builds:
- reproduced with rev <= 14073,
- not reproduced with rev >= 14076;
this crash was AFAICT fixed with the merge of the SelContainer branch in rev 14074:
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14074

Changed in inkscape:
assignee: nobody → Mc (mc...)
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers