Inkscape 0.91 crashes when selecting multiple objects under Chinese/Taiwan(zh-tw) locale

Bug #1428967 reported by Paul Wan
138
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Inkscape
High
jazzynico
inkscape (Ubuntu)
High
Unassigned

Bug Description

Inkscape0.91 crashes under interface using Chinese/Taiwan(zh-tw) when trying to group object, but inkscape0.91 will not crashes under interface using English or Chinese/China (zh-cn) !!
Thank you so much!

Paul Wan (renue100)
Changed in inkscape:
status: New → Incomplete
status: Incomplete → New
Revision history for this message
jazzynico (jazzynico) wrote :

Reproduced on Crunchbang Waldorf, Inkscape trunk rev. 13967. Inkscape crashes when selecting two (or more) objects.
Steps:
1. Draw a couple of objects (rectangles, circles...).
2. Select everything with Ctrl+A or by dragging with the mouse.
-> Crash.

Not reproduced with English and French UI.
Not reproduced with 0.48.3.1.

Changed in inkscape:
importance: Undecided → High
milestone: none → 0.91.1
status: New → Triaged
tags: added: crash ui
Revision history for this message
jazzynico (jazzynico) wrote :

Forgot a step:
1b or 3. Switch to the selector tool.

Revision history for this message
jazzynico (jazzynico) wrote :
jazzynico (jazzynico)
tags: added: translation
Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
status: Triaged → In Progress
Revision history for this message
jazzynico (jazzynico) wrote :

Fix committed in the trunk, rev. 13968.
Workaround applied to the 0.91.x branch, rev. 13734.

Note that the fix required a change in the original strings, and thus backporting it is a bit complicated (we would have to update all the translations, which is something we usually don't do for bugfix releases). As a workaround, I have marked the entry that caused the crash "fuzzy" (the message is thus partially translated, but Inkscape doesn't crash anymore):

#: ../src/selection-describer.cpp:215
#, c-format, fuzzy
msgid "<b>%i</b> objects selected of type %s"
msgid_plural "<b>%i</b> objects selected of types %s"
msgstr[0] "已選擇類型 %s 的 <b>%i</b> 個物件"
msgstr[1] "已選擇類型 %s 的 <b>%i</b> 個物件"

JFYI, gettext requires that % fields follow the original order (here %s must be placed after %i). If not, it causes runtime issues.
In the trunk, I have modified the code so that we now use %1$i and %2$s and no longer need to follow the original order.

Changed in inkscape:
status: In Progress → Fix Committed
Revision history for this message
Sam Lin (itrs-lin) wrote :

I think you may leave source code unmodified as
"<b>%i</b> objects selected of type %s"

then just modify po file as

msgid "<b>%i</b> objects selected of type %s"
msgid_plural "<b>%i</b> objects selected of types %s"
msgstr[0] "已選擇類型 %2$s 的 <b>%1$i</b> 個物件"
msgstr[1] "已選擇類型 %2$s 的 <b>%1$i</b> 個物件"

that should work and apply to previous version. (i tested on 0.91)

Revision history for this message
jazzynico (jazzynico) wrote :

Fix committed in the 0.91.x branch rev. 13744 (replacing the workaround from rev. 13734).
Thanks for your test and suggestion, Sam!

Revision history for this message
V字龍(Vdragon) (vdragon) wrote :

This bug still needs to be fixed in Ubuntu 14.04

tags: added: trusty
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed
Revision history for this message
Chao-Kuei Hung (ckhung0) wrote :

This bug is still present in lubuntu 16.04.

Revision history for this message
zollac (kyle2160k) wrote :

Can confirm. I'm on Ubuntu 16.04 and still have to fix the mo file manually.

Revision history for this message
jazzynico (jazzynico) wrote :

Sadly we didn't manage to release 0.91.1 (or 0.92) for the latest LTS Ubuntu. Let's hope 0.92 will be available in the updates (or backports) repository.

tags: added: xenial
Changed in inkscape (Ubuntu):
importance: Undecided → High
Revision history for this message
林博仁(Buo-ren, Lin) (buo-ren-lin) wrote :

Hi, I (tried to) improve the title a bit, feel free to change it.

summary: - Inkscape0.91 crashes under interface using Chinese/Taiwan(zh-tw)
+ Inkscape 0.91 crashes when selecting multiple objects under
+ Chinese/Taiwan(zh-tw) locale
Revision history for this message
朧月夜霧起 (aspirin-eny) wrote :

bug confirmed on archlinux with inkscape version 0.91 r13725 (Nov 26 2016).

Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
V字龍(Vdragon) (vdragon) wrote :

I'd like to point out that the ubuntu package isn't really "Fix relased" at least on Ubuntu 16.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers