Rendering incorrect when un-clipping grouped objects

Bug #1428535 reported by elecman on 2015-03-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Mc

Bug Description

When grouped objects are un-clipped, the rendering is incorrect.

To reproduce:

-Draw a square which has a fill.
-Draw another square below the first one.
-Group the two squares together.
-Create a third square in the middle which partially covers the first two squares.
-Set the third square to the top of the layer.
-Select all three squares and select Object->Clip-Set.
-Now select Object->Clip->Release.
-Notice the parts of the first two squares which were previously clipped off with the Clip-Set command are not rendered correctly as they have parts still missing.
-Zoom in to refresh the screen which solves the issue.

Inkscape: 0.91
OS: Win 7

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91 r13725 and 0.91+devel r13966 on OS X 10.7.5 as described.

tags: added: clipping renderer-cairo
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

Testing archived builds on OS X 10.7.5:
* not reproduced with
- Inkscape 0.47 r22583, 0.48.5 r10040
- Inkscape 0.49+devel r10325 (prior to cairo-rendering merge)
- Inkscape 0.49+devel r10326 (new cairo-renderer)
* reproduced with
- Inkscape 0.49+devel r10588 (before removal of libnr)
- Inkscape 0.49+devel r10589 (libnr gone)
- Inkscape 0.49+devel r10795 and later.

No archived builds locally available between r10326 and r10588 - likely related to the rendering cache (originally merged in r10451). Likely mentioned in earlier reports (or comments), since the issue exists in trunk for quite some time now.

tags: added: groups regression
su_v (suv-lp) on 2015-03-05
Changed in inkscape:
milestone: none → 0.92
jazzynico (jazzynico) wrote :

Also reproduced on Windows XP (32 bit) with Inkscape trunk rev. 14221.

Changed in inkscape:
status: Confirmed → Triaged
Mc (mc...) wrote :

fixed in r14784

Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers