trunk: moving a selection of frame and text-flowed-into-frame displaces text (rev >= 13634)

Bug #1426613 reported by su_v on 2015-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico
0.92.x
Medium
jazzynico

Bug Description

Steps to reproduce:
1) launch trunk (new doc, new default prefs)
2) draw a shape (e.g. rect, or ellipse)
3) create a regular text object
4) select all (Ctrl+A)
5) flow text into shape (Alt+W)
6) select all (Ctrl+A), grab with mouse and move the selection

Expected result:
The shape and the text keep their relative position once the selection is released at new position

Actual result:
The text is displaced and no longer in the same relative position to the frame as originally.

Reproduced with Inkscape 0.91+devel r13937 on OS X 10.7.5.

Based on tests with current stable, and archived trunk builds:
- not reproduced with Inkscape 0.48.5 r10040, 0.91 r13725,
- not reproduced with Inkscape 0.91+devel rev <= 13632,
- reproduced with Inkscape 0.91+devel rev >= 13634;
it seems that this unexpected behavior was likely introduced with the changes in r13634:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/13634

Revision 13634: Initial removal of box3d outdated GTKish macros.
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13634

su_v (suv-lp) on 2015-02-28
Changed in inkscape:
milestone: none → 0.92
jazzynico (jazzynico) wrote :

Confirmed on Windows XP (32 bits) with Inkcsape trunk rev. 13963.
Not reproduced with 0.48.5.

Changed in inkscape:
status: New → Triaged
jazzynico (jazzynico) on 2016-08-29
Changed in inkscape:
importance: Undecided → Medium
jazzynico (jazzynico) wrote :

Patch tested on Xubuntu 16.04, lp:inkscape/0.92.x rev. 15353.

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
milestone: 0.92 → 0.93
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Fixed in lp:inkscape rev. 15522.

Note that the trunk patch was very small compared to the one for the 0.92.x branch due to code refactoring.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Fixed in lp:inkscape/0.92.x rev. 15385.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers