Rounded rectangle parameters Rx and Ry rescale on every new load if document units = mm.

Bug #1424798 reported by Alvin Penner on 2015-02-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Alvin Penner

Bug Description

this may be related to Bug 1239682, I am not sure. Reporting it separately here because the steps to reproduce are somewhat different, possibly simpler.

- running Windows XP, Inkscape rev 13938
- using empty preferences file, default.svg document with mm as document units
- start Inkscape
- click on rectangle tool, F4
- set Rx = Ry = 10 mm
- close Inkscape without drawing anything
- start Inkscape again, click on F4
- note that Rx = Ry = 37.795, not 10
- close Inkscape without drawing anything
- start Inkscape again, click on F4
- note that Rx = Ry = 142.848, not 10
- draw a rectangle just to confirm the the corners are extremely rounded as expected based on the high Rx, Ry

- each fresh load of Inkscape seems to trigger a new rescale of the Rx, Ry values

- not reproduced if using the file default_px.svg as a startup template file

Alvin Penner (apenner) on 2015-02-23
description: updated
Alvin Penner (apenner) wrote :

just 2 more pieces of info:
- the parameters W and H are also being rescaled at the same time, but one would normally not pay attention to that because they get overwritten as soon as something is drawn
- the rescaling is occurring during the file save process, not the file load. In other words, if you interrogate the preferences to see the values of Rx, Ry, they will agree with what appears on the next load, not the previous one

rickmastfan67 (rickmastfan67) wrote :

I'm just curious, but where is this 'default_px.svg' file stored? I looked everywhere in my Inkscape install folder and can't find it.

Alvin Penner (apenner) wrote :

this file is not present in Inkscape .91. It is present in trunk in the directory Inkscape\share\templates.In INkscape 0.91 I think the closest analog is the file default.svg which has document units of px.

rickmastfan67 (rickmastfan67) wrote :

That's what I kinda thought when I looked at my install of 0.91, but just wanted to be sure a file wasn't missing.

Anyways, the default.svg isn't completely in px units in 0.91. Question #262678 ( https://answers.launchpad.net/inkscape/+question/262678 ) mentions this. Maybe I should have made it as a bug, but not 100% sure because of your comment.

Alvin Penner (apenner) wrote :

reproduced on Inkscape 0.48.1, built on or about 02/23/2011, using the startup file default_mm.svg. In DOS the startup command was:
D:\Program Files\Inkscape>inkscape_48_1 share\templates\default_mm.svg

Alvin Penner (apenner) wrote :

fix committed to rev 13943

Changed in inkscape:
status: New → Fix Committed
assignee: nobody → Alvin Penner (apenner)
su_v (suv-lp) on 2015-05-09
Changed in inkscape:
milestone: none → 0.92
su_v (suv-lp) on 2015-08-08
tags: added: shape-editing units
su_v (suv-lp) on 2015-10-01
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13827.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers