Unable to edit/create symbols

Bug #1419345 reported by Lawrence Gray on 2015-02-07
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

There are no commands in the Object Menu to convert symbol to group and vice-versa as detailed in the release notes 0.91 section 5.7. The Symbols Dialog Wiki page details the menu items I expect to see.

Tried with a 32 bit installation on Win XP - SP3 and a 64 bit installation on Win 7.

tags: added: symbols
su_v (suv-lp) wrote :

@Martin - any chance you could update the symbols blueprint in the wiki with your latest changes how symbol creation and editing now works?

The same kind of question has come up on irc, on twitter and elsewhere.

tags: added: documentation ui
David Gander (davidgander) wrote :

For the benefit of anyone searching for this and as ~suv suggests:

It looks like the way of adding symbols has been changed since the release notes were written.
The symbols dialog can be opened by going to Object->Symbols (Shift-Ctrl-Y)

A symbol can be added by selecting a group of objects and clicking on the "Add symbol from the current document" button at the bottom left of the Symbols sidebar (see attachment)

@davidgander

Yes, but this is not what has been asked. How do I edit a symbol? The old "Symbol to Group" command is gone.

David Gander (davidgander) wrote :

That's a good point, it looks like you have to do this:

If the symbol was added from your current document, you have to remove it from the "symbol tray", which places it back in the document, where it can be un-grouped and edited.

The help text at the bottom of the window says that if you hover over the icon.

If you want to edit one of the symbols from the in built set of symbols - I had to navigate to where these are stored - on Linux typically /usr/share/inkscape/symbols and open one of the svg files there, then perform the same procedure as above.

Is there still no better solution to this? I don’t know why the behaviour was changed, it seemed to make sense the way it was described in the release notes. Having to find a system file in your config directory to be able to edit a symbol seems no good UX. But anyway, the documentation should at least describe the actual behaviour.

Hachmann (marenhachmann) wrote :

You need to do Edit > Clone > unlink Clone.

I have no idea where this is documented at all (as there is no documentation for that feature, to my knowledge) - can you refer me to that place?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers