0.91, 64-bit unable to associate SVG with Inkscape in Win7, 64-bit

Bug #1417146 reported by Brynn on 2015-02-02
This bug affects 3 people
Affects Status Importance Assigned to Milestone

Bug Description

Hi Friends,
This on win7, 64-bit and Inkscape 0.91, 64-bit (I installed the 7z version, but there's another report in InkscapeForum.com from someone who installed the MSI version).

Steps to reproduce:

-- right-click on any SVG file
-- choose Open with
-- in Open With dialog, click Browse button
-- locate inkscape.exe, click Open
-- Inkscape does not appear in the Open With dialog, as it normally should
-- if I click OK anyway, it just applies whatever program was highlighted (in my case, now IE is shown as the default)

Please let me know if I can provide files or further info.

Thanks for your help :-)

su_v (suv-lp) on 2015-02-02
tags: added: win64
Patrick Storz (ede123) wrote :

This is actually a Windows bug (Inkscape could possibly implement a workaround, though).

To manually work around it:
- Open "regedit.exe"
- Browse to "HKEY_CLASSES_ROOT\Applications\inkscape.exe"
- Delete this key ("inkscape.exe")

Afterwards you should be able to associate SVG files with Inkscape normally.

The reason for the bug is that Windows seems to have problems to differentiate between
 - "C:\Program Files\Inkscape\inkscape.exe" and
 - "C:\Program Files (x86)\Inkscape\inkscape.exe"
Therefore if you had the 32-bit version installed and update to the 64-bit version, the reported behavior occurs.

Brynn (brynn4inks) wrote :

Oh, that's awesome. Thank you so much.

It worked perfectly, without even a restart needed.

It would be nice if Inkscape could make a workaround. But with a solution as easy as this, we'll be able to answer this question, which undoubtedly will be posted repeatedly in forums.

And actually, maybe I can put it in the faq, if the questions become quite numerous.

Anyway, thanks again :-)

su_v (suv-lp) on 2015-02-03
tags: added: packaging
Jordan (jordanu) on 2015-02-06
Changed in inkscape:
status: New → Confirmed
theAdib (theadib) wrote :

could you please report the language that you have configured on windows? Are you using something different from english locales?
Regards, Adib.

Patrick Storz (ede123) wrote :

I'm running Windows 7 with German locale.
Is the issue I described in comment #1 actually only happening in combination with Windows' folder name translation (and not on an English machine) or why are you asking?

Don Cady (doncady) wrote :

This is definitely an installer/packaging issue. Sure, windows has this quirk. But if the installer cleaned up the 32bit version entries, this behavior wouldn't occur. See bug 1417070

theAdib (theadib) wrote :


I have no German Windows at hand (i use english Windows 7 with german Keyboard layout)
I have UAC in place, so whenever I install something then I am asked for admin password.
pls check and report following registry settings

HKEY_CLASSES_ROOT\.svg : there should be an element "OpenWithProgIds" under which there should be one element with content "inkscape.svg"
also I see here
where there is one element containing "inkscape.svg"

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\inkscape.svg : this should handle open actions using inkscape

Patrick Storz (ede123) wrote :

Hi theAdib,

I doubt it's of much help (I don't see any localized content in there) but here's the registry keys you mentioned.

Please note, that I already worked around the issue as described in comment #1!
Therefore if there was any obvious issue before, it's probably no longer apparent from the registry keys by now.

Brynn (brynn4inks) wrote :

Note that I'm having this problem with version 0.92, as well.

I'll follow the instructions above, as before.

Thanks :-)

William Berzoff (berzoffw) wrote :

Here the same problem on Windows 7 x64, with Inkscape version 0.92.1 r15371 x64
Using the work around from post #1, has fixed the issue.
SVG (and SVGZ) files are now properly associated with the SVG file extension.

Patrick Storz (ede123) wrote :

@William: Your issue seems actually unrelated to the 32-bit -> 64-bit switch.

From a quick look into the attached registry keys it's apparent that Windows somehow (how exactly is still something to determine) messed up the registry entry for "inkscape.exe" using Internet Explorer to open associated files instead. As a result - even if Inkscape was set as default application for .svg files - Internet Explorer would still be used to open them.

Patrick Storz (ede123) wrote :

Same issue again on Window 7 x64 today:
- I uninstalled Inkscape 0.91
  (was installed using the MSI installer)
- I tried to "Open with" an .svg and wanted to choose inkscape.exe
  (in a non-system location) from an extracted 7z archive
- Windows did not let me pick Inkscape to "Open with"

Unfortunately I do not remember what happened on this machine before I installed Inkscape 0.91. I suspect I had an earlier version installed from an .exe installer but I could be wrong...

Attached are the registry keys when I initially tried to set the association.

Brynn (brynn4inks) wrote :

I'm having trouble switching my association from 0.92.2 to 0.92.3. Both are from the 7z package, and both are in Program Files (i.e. the 64-bit versions). Windows 7 Pro, 64-bit

Deleting the key in the Registry Editor, as suggested above, fixed it.


To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers