Inkscape crashing on close with a Segmentation fault. (win64)

Bug #1412365 reported by rickmastfan67 on 2015-01-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Eduard Braun
Inkscape Devlibs for Windows 64-bit
Undecided
Unassigned

Bug Description

Inkscape 0.91pre3 r13670 win64
Windows 7 x64

NOTE: This crash is only noticeable via gdb. Tried the same steps below with the debug on 0.48.5 win32, and it exits correctly without crashing per gdb.

Steps to reproduce:
1. Start out by deleting (or renaming the folder for) your current profile for Inkscape (this proves it's not a profile bug).
2. Start Inkscape so it will create a new profile.
3. Once Inkscape has loaded, close the program.

What should happen:
Inkscape should close 'normally'.

What happens:
Inkscape crashes with a sigsegv.

I've attached the log from gdb to this ticket. Only thing redacted from it is my user account name.

This happens every time you close Inkscape, with or without a profile already present per gdb.

rickmastfan67 (rickmastfan67) wrote :
Liam P. White (liampwhite) wrote :

In the gdb log you can see that the signal is coming from libwinpthread (a POSIX thread library for Windows).

Assuming that winpthread does not have a serious flaw causing this, my assumption is that winpthread is resetting the signal handler for SIGSEGV and using it as a way to control memory access for other threads, not to indicate program fault.

su_v (suv-lp) on 2015-01-19
tags: added: win64
rickmastfan67 (rickmastfan67) wrote :

Well, all I know is that the 32bit version of Inkscape 0.91pre3 r13670 says it exits 'normally' when I try the same steps above.

So, if there really is a problem, it's restricted to the x64 build.

Liam P. White (liampwhite) wrote :

The normal 32-bit build uses a "normal" libpthread; the 64-bit build uses a newer one with the same API called winpthread.

rickmastfan67 (rickmastfan67) wrote :

Well, here's the backtrace if this is of any help.

rickmastfan67 (rickmastfan67) wrote :

Well, with the backtrace I posted above, it seems that libaspell-15.dll is part of why the crash happens. Don't know if that well help narrow this down.

rickmastfan67 (rickmastfan67) wrote :

Looks like this might be a bug in building Inkscape with mingw and/or aspell.

See here: http://sourceforge.net/p/mingw-w64/bugs/432/

Identical backtrace for steps #5 - #10 at that link.

summary: - Inkscape crashing on close with a sigsegv
+ Inkscape crashing on close with a Segmentation fault. (win64)
tags: added: crash
Eduard Braun (eduard-braun2) wrote :

Just "rediscovered" this while investigating a dependent issue, see bug #1714278.

Issue is definitely a bug in Aspell when built with winpthread from mingw-w64.

Eduard Braun (eduard-braun2) wrote :

This issue was resolved for MSYS2 builds by patching Aspell see bug #1714278 for details.

If anybody wants to verify the fix, [1] is the first CI build with the patched version of Aspell.

[1] https://ci.appveyor.com/project/inkscape/inkscape/build/0.92.x-478

Changed in inkscape:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Eduard Braun (eduard-braun2)
milestone: none → 0.92.3
Bryce Harrington (bryce) on 2018-05-12
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers