Crash with color widget used in procedural template (trunk, 0.91.x)

Bug #1402182 reported by su_v on 2014-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

A procedural template which uses a color widget (<param type="color" … />) causes inkscape to crash as soon as the template is selected in the 'File > New > Templates...' dialog.

Steps to reproduce:
1) install attached custom extension
2) launch inkscape trunk or 0.91.x
3) open templates dialog (Ctrl+Alt+N)
4) select 'Color...' in the list of available templates
--> crash

Test the same extension as normal effect:
5) relaunch inkscape
6) run 'Extensions > Debug > Page Color...'
7) change the page color and opacity in either tab
--> works as expected (no crash).

Test the same procedural template without the color widget:
8) quit inkscape
9) comment out line 14 in 'empty_color.inx'
10) launch inkscape, repeat step 4
--> no crash, but no color widget for easy color selection either.

Reproduced with Inkscape 0.91+devel r13795 and 0.91pre3 r13685 on OS X 10.7.5

Test case (extension) attached:
- empty_color.py
- empty_color.inx (template, using the same script)
- page_color.inx (effect, using the same script)

Extension also available in my procedural templates playground:
<lp:~suv-lp/+junk/inkscape-procedural-templates>

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :
su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

Backtrace (Inkscape 0.91+devel r13795, debug build 64bit, GTK+/X11 2.24.25)

su_v (suv-lp) on 2014-12-13
description: updated
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk rev. 14221.

Changed in inkscape:
status: New → Triaged
jazzynico (jazzynico) wrote :
Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
importance: Undecided → Medium
milestone: none → 0.91.1
status: Triaged → In Progress
milestone: 0.91.1 → 0.92
jazzynico (jazzynico) wrote :

Patch tested on Xubuntu 15.04 (64 bit) and Windows XP (32 bit) with Inkscape trunk rev. 14221.
No regression found with other extensions and filters that use the color widget.

Not sure if we should backport it to the 0.91.x branch (no color widget in the current templates).

jazzynico (jazzynico) wrote :

Fixed in the trunk, rev. 14223.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

On 2015-06-29 17:49 (+0200), jazzynico wrote:
> Not sure if we should backport it to the 0.91.x branch (no color
> widget in the current templates).

Are there specific reason why not to backport? Any user of Inkscape 0.91.x can (or could) write and/or use a custom procedural template with color widget(s) …

On 2015-06-30 10:23 (+0200), jazzynico wrote:
> Fixed in the trunk, rev. 14223.

Fix confirmed with r14224 on OS X 10.7.5 - thanks a lot!

jazzynico (jazzynico) wrote :

~suv> Any user of Inkscape 0.91.x can (or could) write and/or use a custom procedural template with color widget(s)

Yes, you're right. I just felt that since there's no official procedural template of that type it wasn't really useful.

tags: added: backport-proposed
su_v (suv-lp) wrote :

Tried to backport the fix (rev 14223) to 0.91.x - doesn't work yet: 0.91.x now crashes when adjusting the color in a procedural template.

Removing backport-proposed tag for now.

tags: removed: backport-proposed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers