Keyboard shortcut editor throws together extensions and filters

Bug #1401993 reported by Hachmann on 2014-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
jazzynico

Bug Description

0.91pre3 on LM 17:

The keyboard shortcut editor lists all filters in/at the end of the extensions section. A filter section is missing.

Perhaps some kind of additional sub-categorisation, reflecting the menu structure, could make the extensions / filter section a bit easier to navigate - or maybe the full, long listing is intentional, as there is, of course, also the search box.

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk rev. 13836.

Note that internally, filters are extensions. But yes, it would be easier to read if they were in different categories.

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: preferences shortcuts ui
jazzynico (jazzynico) wrote :

Patch tested on Windows XP, Inkscape trunk rev. 13836.

Since the shortcut preferences dialog uses the verb group to sort its entries, I had to compare the verb id to extract the filters (extensions and filters share the same group, but filters have a specific id prefix).

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
milestone: none → 0.92
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 13845.

Changed in inkscape:
status: In Progress → Fix Committed
Hachmann (marenhachmann) wrote :

Thank you, Nico :D

ScislaC (scislac) wrote :

Backported in 0.91.x r13706.

Changed in inkscape:
milestone: 0.92 → 0.91
jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers