'Take from selection' button should be greyed out at startup

Bug #1401782 reported by jazzynico on 2014-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

Follow-up to Bug #1363436 "Info missing that restart is needed for some inkscape settings when changed".

The Preferences dialog is not correctly initialized: the button 'take from selection' is only greyed out after I have switched between the radio buttons once (last used -> take from selection -> last used), while I would expect it to be greyed out only based on the currently selected radio button. This is reset on every restart of Inkscape (so the button is no longer greyed out, if it was before).

Related (bug not exactly the same): bug #569889 "Take From Selection buttons in preferences are always enabled even if there is no selection".

jazzynico (jazzynico) wrote :

Patch tested on Windows XP, Inkscape trunk rev. 13795.

jazzynico (jazzynico) wrote :

Also tested on Crunchbang Linux and committed in the trunk, rev. 13797.

Changed in inkscape:
status: In Progress → Fix Committed
Hachmann (marenhachmann) wrote :

Thank you! :D

ScislaC (scislac) wrote :

Backported in 0.91.x r13701.

Changed in inkscape:
milestone: 0.92 → 0.91
su_v (suv-lp) on 2015-01-16
tags: removed: backport-proposed
jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers