Option to disable space bar panning

Bug #1401593 reported by Analog on 2014-12-11
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Mc

Bug Description

on .91 pre 3 there currently is no option to disable space bar panning. I use space bar to switch context and the panning feature is constantly taking over instead of doing what i'd expect from 10 years of previously using the older version of inkscape. Can there be an option to turn this off in the new versions.

su_v (suv-lp) on 2014-12-12
Changed in inkscape:
importance: Undecided → Wishlist
tags: added: preferences ui
Mark Crutch (markc-qsiuk) wrote :

I'm also struggling with space bar panning getting in the way both when toggling back to the selector tool (per the original report), but also when trying to stamp copies of objects.

An alternative to exposing a preference option might be to tweak the code that triggers panning so that the space bar has to be held down beyond a particular threshold (e.g. for at least 100ms) before panning commences. This would reduce the likelihood of it interfering with toggling and stamping, both of which tend to be done with a quick press and release of the bar.

Brynn (brynn4inks) wrote :

Another user wishing to disable the "always on" panning: http://www.inkscapeforum.com/viewtopic.php?f=5&t=18457.

And the following may or may not be a separate issue. Let me know if you want me to make a separate report.

When I press the space bar on my computer, the cursor stops moving. It's completely frozen, and I can only move it by releasing the space bar. This may be related to my mouse settings (I use an external touchpad mouse on Win7, 64-bit) because it happens no matter which program I have open. Since I don't use panning, I don't plan to investigate. But if it will help with this inkscape issue, I'll be glad to investigate further.

Matthew Woehlke (mw-triad) wrote :

Will someone please change the severity on this bug? This is NOT a wishlist item, it is a HORRIBLE usability regression, to the point that I have actually downgraded to 0.48.4 to avoid it. An option is not a nice to have, it is a requirement, and it needs to be OFF by default. (Or implement Mark's suggestion of having a significant time threshold before spacebar starts a pan, regardless of distance. Note that this should *replace* the distance threshold entirely, so that small pan motions are possible.)

I am used to using spacebar all the time to quickly switch between selection and whatever tool I am using. I effectively can no longer use the space bar without entirely removing my hand from the mouse, as failing to do so causes tool switching to not only not work, but makes the view slide (pan) wildly all over the place. This severely damages my ability to work quickly.

LaCatrina (lacatrina) wrote :

I agree with Matthew's opinion. Space bar panning is so cruel that I still use version 0.48.

LaCatrina (lacatrina) on 2015-04-30
Changed in inkscape:
assignee: nobody → LaCatrina (lacatrina)
assignee: LaCatrina (lacatrina) → nobody
status: New → Confirmed
Tiffany (tiffany-g-harvey) wrote :

This is more than a wishlist item, it also causes a bug. When I'm trying to switch tools, the panning sometimes get stuck on my program so that I can't do anything else (several times a day). I was having to save, close, and reopen the program, but then I found I could get it to snap out of it finally by hitting Ctrl and arrow keys a few times until that finally moved the page.

Anyone else having that problem? Either way, the normal panning alone is horribly annoying. I have to lift my pen high above the tablet every time I switch tools so that I don't trigger it.

ScislaC (scislac) wrote :

Tiffany: Thank you for your report. We have had another report where a tablet user had panning issues too when trying to switch tools. We will look into this and see how it can best be resolved. Given that the number of issues who report issues vs experience issues is really low, please continue to give us this feedback so we can try to address these issues.

ScislaC (scislac) wrote :

dammit, given that the number of USERS (not issues) who report issues... *sigh* I'm walking away from the keyboard

Analog (matt-poepping-7) wrote :

This is also a horrible issue for me. It makes getting anything done very hard. All I really need is an option to disable the space bar pan.

Lucian (lucian-j) wrote :

Agreed, this is immensely frustrating in 0.91, especially for tablet users. More than a wishlist item in my book. At the very least can we see a preference to disable (even if means editing the preferences.xml for the time being).

Matt Sim (mr-matt-sim) wrote :

So frustrating!
How did this feature even get included? What problem was it intended to solve?
Definitely a usability bug -- input modality conflict.

It's implicit in the Inkscape code...
I disabled it directly in the source.
In the file "src/ui/tools/tool-base.cpp", line 700, I needed to comment:
            //panning = 4;

            //this->space_panning = true;
            //this->message_context->set(Inkscape::INFORMATION_MESSAGE,
            // _("<b>Space+mouse move</b> to pan canvas"));

and compiled it....
If anybody want the binary, contact me, and I can send my binary.

Sorry for my english.

Mc (mc...) wrote :

Attached a partial fix (still needs to update all the localization)

Mc (mc...) wrote :

committed to r14372

Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Confirmed → Fix Committed
milestone: none → 0.92
Jef Lemaire (jeflemaire) wrote :

Tested and working as expected for me. Good job, Mc

LaCatrina (lacatrina) wrote :

Hi there, can someone tell me how to get a compiled Windows-Version with this fix?

jazzynico (jazzynico) wrote :

@LaCatrina - You can find win32 development packages here: http://download.tuxfamily.org/inkscape/

Jef Lemaire (jeflemaire) wrote :

I've found a problem with this change: when panning with the space key is disabled pressing the space key while in text edit mode results in the text object being selected. This is a serious regression. It makes editing text strings of more than a couple words a real struggle.

Mc (mc...) on 2015-10-03
Changed in inkscape:
status: Fix Committed → In Progress
Mc (mc...) wrote :

I tried to fix that in r14394

Changed in inkscape:
status: In Progress → Fix Committed
Jef Lemaire (jeflemaire) wrote :

Perfect. I've been using Inkscape r14394 for a few hours now and didn't notice any issues anymore with this.

rob (basel) wrote :

I just pulled the 0.91 devel from the repository with "git bzr clone lp:inkscape inkscape" and built it. The spacebar issue is still there (Linux Mint 17.2). Did I build the correct version which supposedly fixes the issue? The latest commit is see is: by jabiertxof at 11/12/2015 10:16

Mc (mc...) wrote :

This bug is not about the "spacebar issue" (probably https://bugs.launchpad.net/inkscape/+bug/1400234 ) but about an option to disable mouse panning. You can find it as a checkbox with the text "mouse move pans when space is pressed" in inkscape properties (ctrl+shift+p)->behavior->scrolling.

You can work around bug 1400234 by disabling pressure-sensitive tablets in inkscape properties (ctrl+shift+p)->input/output->input devices (uncheck "use pressure sensitive").

Mattarth (mattarth) wrote :

@Mc, is this true for the release version of 0.91 on Windows, because I cannot find that check box anywhere (definitely not in scrolling). Thanks in advance

Mc (mc...) wrote :

No, "Fix Committed" means that the code is there in the development version, but not yet in released version (It's milestoned for 0.92)

Larry Sunshine (ls007sunshine) wrote :

This is a joke.

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers