Document units should not differ from user units for 0.91

Bug #1387864 reported by ScislaC on 2014-10-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Roadmap for 0.91: (this bug)
=================
√ Everything should use only pixels as is (mostly) done in 0.48 (including templates). For guides, grids, 3dbox see bug #1400702.
√ The ability to switch document units should be disabled (it's broken in several ways).
√ Font size should be stored in pixels.

It should be possible to avoid overwriting Inkscape version until any necessary conversion is done. If a conversion appears to be needed, a pop-up can ask the author if it should be done.

Roadmap for 0.92: (bug #1389723)
=================
- Non-pixel units are allowed but everything in a document should use the same units including guides and grids.
- (Guides and grids need code to do this.)
- An extension that saves a document in pixels should be added to allow backwards compatability with 0.91.

See also:
=========
Related mailing list threads:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/44423>
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/45073>

Related wiki page:
<http://wiki.inkscape.org/wiki/index.php/Units_In_Inkscape>
<http://wiki.inkscape.org/wiki/index.php/Units_In_Inkscape:_Document_Unit_Change>

Original description:
=====================
Per discussion on mailing list relating to Grids/Guides, etc.

su_v (suv-lp) on 2014-10-30
tags: added: units
su_v (suv-lp) wrote :

It might be useful to coordinate with the proposed changes (for 0.91 only) in
- Bug #1384915 “viewBox numerical errors caused by default.svg file”
  <https://bugs.launchpad.net/inkscape/0.91.x/+bug/1384915>

description: updated
su_v (suv-lp) on 2014-11-08
description: updated
Changed in inkscape:
importance: Medium → High
su_v (suv-lp) on 2014-11-09
description: updated
ScislaC (scislac) wrote :

Modified patch (no string changes) for 0.91.x from Johan's commit to trunk r13748. I have yet to do thorough testing with this.

ScislaC (scislac) wrote :

This supercedes the previous patch. It is a combination of r13748, 13750, & r13751 from trunk backported to 0.91.

ScislaC (scislac) wrote :

Supersedes (woohoo multiple spellings) previous patch. Added fix from trunk r13755.

su_v (suv-lp) on 2014-11-25
Changed in inkscape:
status: Confirmed → In Progress
su_v (suv-lp) wrote :

Updated patch to include fix from r13759 (supersedes previous ones).

ScislaC (scislac) wrote :

Updated to include fix from r13760 (supersedes previous).

ScislaC (scislac) wrote :

Supersedes all previous patches, this backports revisions 13748, 13750, 13751, 13753, 13755, 13758, 13759, 13760, plus has a units.xml update via email from Tavmjong.

su_v (suv-lp) on 2014-12-09
description: updated
su_v (suv-lp) wrote :

Todo:
- review non-default templates in 0.91.x, add viewBox if missing (in px based on 90dpi)
- review and test commits for bug #1384915 which haven't been backported yet
- …

description: updated
su_v (suv-lp) on 2015-02-23
no longer affects: inkscape/0.91.x
Changed in inkscape:
status: In Progress → Fix Released
tags: removed: blocker
su_v (suv-lp) on 2015-02-24
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers