trunk: focus indicator for dockable dialogs introduced regressions with GTK2/Quartz (rev >= 11377)

Bug #1363998 reported by su_v on 2014-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
su_v

Bug Description

Follow-up to
- Bug #950556 “Docked dialogs lost focus indicator (shading of title bar) in trunk”
  <https://bugs.launchpad.net/inkscape/+bug/950556>

Symptoms:
- Constant CPU load of 12-15% if inkscape trunk is the active application and has a detached dialog open (e.g. Document Properties)
- CPU load increases to 100% if inkscape is put in the background while a detached dialog is open (a different application is active and has focus).
- The main dock in the document window doesn't resize correctly while a dialog is open in a floating dock (e.g. Document Properties)
- Breaks 'Path > Trace Bitmap' (hangs in trace mode, never inserts resulting (group of) paths)

Steps to reproduce dock resize failure:
1) launch inkscape trunk with default (new) prefs
2) open Document Properties (Shift+Ctrl+D)
3) switch focus back to main window
4) open 'Layers' dialog (Shift+Ctrl+L)

Expected result:
Layers dialog opens in the main dock of the document window

Actual result:
Layers dialog appears to fail to open (actually it is open, but the dock doesn't resize to the minimal width until the floating dock is closed, or minimized to the dock bar in the main window).

Not reproduced with archived build r11376, reproduced with r11378.

System Info:
- Mac OS X 10.7.5 Lion
- archived builds: GTK+/Quartz 2.24.17, GLib 2.34.3
- current trunk: GTK+/Quartz 2.24.24, Glib 2.40.0

Using current trunk build (r13537) with the attached diff to partially revert r11377 prevents this from happening: no more increased CPU load as described, and the dock resizes as expected when opening the layers dialog. The drawback is that the focus indicator is no longer drawn in the title bar of the dialog which has current focus.

Notes:
- The first issue mentioned in bug #950556 (comment #5) no longer occurs with current trunk because the preferences dialog is now a forced floating dialog.
- Builds with GTK+/X11 (same versions of dependencies, same revisions of trunk) are not affected.

su_v (suv-lp) wrote :
description: updated
su_v (suv-lp) on 2014-09-01
description: updated
su_v (suv-lp) on 2014-10-21
Changed in inkscape:
importance: Undecided → Medium
milestone: 0.91 → 0.92
su_v (suv-lp) wrote :

Possibly related discussion in upstream report:
<https://bugzilla.gnome.org/show_bug.cgi?id=671701#c8>

su_v (suv-lp) on 2015-05-18
description: updated
su_v (suv-lp) wrote :

Committed in r14319.

Changed in inkscape:
assignee: nobody → ~suv (suv-lp)
status: New → Fix Committed
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13809.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
su_v (suv-lp) on 2017-01-12
tags: added: gtk-quartz
removed: gtk-osx
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.