Italian translation updates for 0.91

Bug #1363245 reported by FirasH on 2014-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
FirasH

Bug Description

This bug will be used to upload Italian translation updates for Inkscape 0.91

FirasH (firashanife) wrote :
FirasH (firashanife) wrote :

Can someone add my name to the Translators list? I've added it to the .po file but no idea how to proceed for the About dialog.
Thanks a lot!

su_v (suv-lp) on 2014-08-29
tags: added: translation
Changed in inkscape:
milestone: none → 0.91
assignee: nobody → FirasH (firashanife)
importance: Undecided → Low
status: New → In Progress
jazzynico (jazzynico) wrote :

Translation updated in the trunk revision 13535 (now 64% translated).
Thanks!

> Can someone add my name to the Translators list?

Done revision 13536.

FirasH (firashanife) wrote :

Here are some more updates/fixes for 0.91.
Around 1000 changes.

jazzynico (jazzynico) wrote :

Translation updated revision 13541 (now 70% translated).
Thanks!

FirasH (firashanife) wrote :

New updates attached.

jazzynico (jazzynico) wrote :

Translation updated revision 13548 (75%).
Thanks!

FirasH (firashanife) wrote :

New update attached.

I found an issue while translating this:
#: ../src/selection-chemistry.cpp:765 ../src/sp-item-group.cpp:329
msgid "Group"
msgstr "Gruppo"

Is it possible to divide the 2 translations of "Group" in 2 independent ones?
One is used as a verb and one as a noun and its impossible to get a correct translation.

Thanks!

FirasH (firashanife) wrote :

If it is needed the problem is at line 12755 of it.po (with the previously attached update applied). I assume its the same even for other languages as .po files are created from a template...

jazzynico (jazzynico) wrote :

Good catch! The "group" in the selection chemistry is somewhat hidden in the undo history, but it should a verb indeed. I'm working on it.

I've committed your translation update revision 13553. Thanks!

jazzynico (jazzynico) wrote :

"Group" is now correctly contextualized as a verb as of revision 13554.

FirasH (firashanife) wrote :

New updated attached!
Thanks jazzynico!

jazzynico (jazzynico) wrote :

Translation updated revision 13558.
Thanks!

FirasH (firashanife) wrote :

Uploaded a new update.

I noticed 2 typos:
1) ../share/extensions/gcodetools.py:3324 - Noting > Nothing
2) ../share/symbols/symbols.h:34 ../share/symbols/symbols.h:33 - Road)," > Road"

jazzynico (jazzynico) wrote :

Typos fixed and translation updated revision 13626.
Thanks!

FirasH (firashanife) wrote :

I think I found something not working in the translations...
5 status messages (lower part of UI) are not translated even if .po file is correctly updated/translated,
here you can find them: src/seltrans-handles.cpp

Thanks! (New translation updates are coming soon)

FirasH (firashanife) wrote :

Here is the latest update!
This includes a full review, line per line of what was already translated, so a lot of typos fixed. In addition some other parts are now translated.

jazzynico (jazzynico) wrote :

Translation updated in the trunk (rev. 13639) and 0.91 branch (rev. 13631).
Thanks!

> 5 status messages (lower part of UI) are not translated even if .po file is correctly updated/translated, here you can find them: src/seltrans-handles.cpp

Confirmed. Investigations in progress.

jazzynico (jazzynico) wrote :

The seltrans handles strings are fixed in the trunk (rev. 13640) and the 0.91 branch (13632).

FirasH (firashanife) wrote :

Thanks jazzynico!
I've just found a file on which I noted some typo a few months ago... Here are some still present small issues:

1) "type :" > "type:"
#: ../share/extensions/dimension.inx.h:4
msgid "Bounding box type :"

2) "Save a Copy" > "Save a Copy..."
#: ../src/ui/dialog/inkscape-preferences.cpp:841
msgid ""
"When this option is on, the \"Save as...\" and \"Save a Copy\" dialogs will "

Bye

jazzynico (jazzynico) wrote :

Typos fixed in the trunk, revision 13673. Thanks for finding them!

Unfortunately it can't be fixed in the 0.91.x branch since we have reached "string freeze", and therefore no string further string changes are allowed. Moreover, it could break translations for already translated languages for which I'm not sure that translators have time to work on it again.
Note that you can use fixed translations for your language even if the original string is incorrect.

FirasH (firashanife) wrote :

Thanks jazzynico!
You're right, it's too late to apply string corrections now, maybe after the release we could backport them?

Speeking about strings I found some that can not be translated:
Object > Arrange > Polar Coordinates > Parametrized: tooltips are only in English (polar-arrange-tab.cpp).

Bye! (new translation update coming soon)

FirasH (firashanife) wrote :

Latest update of the Italian translation (94%), very likely the last one for 0.91 release.

jazzynico (jazzynico) wrote :

Translation updated in the 0.91.x branch (rev.13648 ) and trunk (rev.13731 ).

Note that I had to change one of your translation due to the following error when checking the po file:
---
it.po: parsing error for `<rettangolo>':
#: ../src/ui/dialog/inkscape-preferences.cpp:918
msgid "Print warning if inappropriate style properties found (i.e. 'font-family' set on a <rect>). Database files located in inkscape_data_dir/attributes."
msgstr "Mostra avviso se vengono trovate proprietà stile inappropriate (es. 'carattere' impostato su un <rettangolo>). File database localizzati in inkscape_data_dir/attributes."
---
All the elements used in the translation must be correct SVG elements, and thus I replaced <rettangolo> with <rect> so that the translation passes the check.

Thanks!

FirasH (firashanife) wrote :

Hello!
Here is a small update for new or changed strings for Symbols dialog.
Translation is still at 94% but I'll probably keep it as with the current update unless I find some typos.
(Only some Extensions are non-translated, I prefer to avoid the translation of things I don't understand, know or specifically find in UI).
Now I'll focus on updating tutorials!

Thanks jazzynico!

jazzynico (jazzynico) wrote :

Translation updated in the 0.91.x branch (rev. 13696) and in the trunk (rev. 13847).
Thanks!

Changed in inkscape:
status: In Progress → Fix Committed
FirasH (firashanife) wrote :

jazzynico, I just updated the Inkscape: Basic tutorial, the .diff is attached.
Could you check if that is correctly updated for 0.91.x so I can update the other tutorials?

(.po file from lp:inkscape-docs)

Thank you so much!!

jazzynico (jazzynico) wrote :

Hi Firas,

Thanks for your tutorial translation.
I see nothing wrong in the PO file, you can safely work on the other tutorials ;)

Just for your information, there's currently only one branch for the documentation. I still hesitate to create a different one for each Inkscape version, but I won't create it before 0.91 is out.

FirasH (firashanife) wrote :

Here is a small fix to Italian UI translation.

FirasH (firashanife) wrote :

Here are Basic+Advanced tutorial updated.
Can be applied for 0.91.x if everything is ok.
Thanks jazzynico!

jazzynico (jazzynico) wrote :

UI translation update in the trunk (rev. 13861) and 0.91.x branch (rev. 13710).

Tutorials in progress...

jazzynico (jazzynico) wrote :

Basic and advanced tutorials updated in the trunk (rev. 13862) and 0.91.x branch (rev. 13711).
Thanks Firas!

jazzynico (jazzynico) wrote :

...and in inkscape-doc rev. 510.

FirasH (firashanife) wrote :

Hello!
I've reviewed my previous updates and fixed some small things!

jazzynico, I noticed that the .po files were updated and some new string are now available.
Could you upload the .po files for the other tutorials as well?
Thanks!

jazzynico (jazzynico) wrote :

Basic and advanced tutorials updated in inkscape-doc rev. 511.

I'll try to regenerate the other po files today.

Thanks!

jazzynico (jazzynico) wrote :

Basic and advanced SVG files updated in the 0.91.x branch (rev. 13724) and trunk (rev. 13878).

We're going to release the final 0.91 package, and thus it's a bit late to update the other tutorials. I'll update the PO files so that you can work on it, but the generated SVG files probably won't be in 0.91 (but it's ok for 0.91.1, if any, and 0.92).

FirasH (firashanife) wrote :

Here is a small fix for 0.91.1. As far as 0.91 is already released, I'll take a bit more time to complete tutorial translations.
Thanks jazzynico!

jazzynico (jazzynico) wrote :

Hi,

Now that 0.91 is out, I'm going to close the report and open a new one for 0.91.1 (https://bugs.launchpad.net/inkscape/+bug/1416839).

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.