cannot set transformation center in this file (rev >= 13512)

Bug #1360953 reported by Formerly Kevin Yin, now disabled on 2014-08-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

Open the attached svg. Create an object (rectangle). Try to move its transformation center.

In the undo history, no entry will be created; that's because the transformation center isn't being set. After deselecting and selecting the object, the object's transformation center will be back to its default.

The file was produced by taking the file in bug 1360946, and setting the path's transformation center's two coordinates to 0.

Inkscape "0.91pre2" x64 r13516 on Windows 8.1.

su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with 0.48.5 r10040
- reproduced with 0.91pre2 r13530

tags: added: regression transformations
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.91
status: New → Confirmed
su_v (suv-lp) wrote :

Based on tests with archived builds on OS X:
- not reproduced with rev <= 13511,
- reproduced with rev >= 13512;
this regression seems to be related to the changes in r13512:
"Fix some transformation center regressions, related to the viewbox/units changes"
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13512>

su_v (suv-lp) wrote :

@Diederik - any chance you could investigate this recent regression reported here?

su_v (suv-lp) on 2014-08-25
summary: - cannot set transformation center in this file
+ cannot set transformation center in this file (rev >= 13512)
Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

My bad, when fixing the old bug I introduced a new bug, sorry for that!

Should have been fixed as of rev. #13534.

Changed in inkscape:
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers