PDF file opened with relative path (cli) crashes on import via poppler

Bug #1351246 reported by su_v on 2014-08-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Tavmjong Bah

Bug Description

Follow-up to
- Bug #1052710 “No PDF preview shown when opening PDF with an relative path”
  <https://bugs.launchpad.net/inkscape/+bug/1052710>

It appears that rev 12127 <http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12127> undid the fix for bug #1052710, and this now triggers a crash when loading the PDF file with 'import via poppler' checked (normal import works ok).

Steps to reproduce:
1) launch current trunk with PDF file as command line argument:
$ inkscape document.pdf
2) check '[x] import via poppler' in the PDF import dialog

--> crash.

Notes:
- Preview is shown / no crash with 'import via poppler' if providing absolute path to the PDF file:
$ inkscape "$(pwd)/document.pdf"

Based on tests with archived builds on OS X 10.7.5:
- not reproduced with rev <= 13408
- reproduced with rev >= 13410
the crash itself is related to
Revision 13409: "merge pdf import via poppler-cairo into native importer"
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13409>

The underlying issue seems likely to be the same as with the missing preview image (which is rendered via poppler-cairo AFAIU).

Reproduced with lp:inkscape r13484 on OS X 10.7.5 and lp:inkscape/experimental r13453 Ubuntu 14.04 (VM 64bit).

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk revision 13484.

Changed in inkscape:
status: New → Triaged
su_v (suv-lp) wrote :

Setting importance to 'Medium' - the risk of data loss due to the crash is low (the file is opened via command line in a new process, and the crash won't affect other open documents with unsaved changes).

Changed in inkscape:
importance: Undecided → Medium
su_v (suv-lp) wrote :

Backtrace with r13502 (debug build, OS X 10.7.5)

su_v (suv-lp) on 2014-10-21
Changed in inkscape:
milestone: 0.91 → 0.92
su_v (suv-lp) on 2015-05-21
summary: - trunk: PDF file opened with relative path (cli) crashes on import via
- poppler
+ PDF file opened with relative path (cli) crashes on import via poppler
su_v (suv-lp) wrote :

Fix committed in r14172.

Changed in inkscape:
assignee: nobody → Tavmjong Bah (tavmjong-free)
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers