scaling with alt fails at 100%

Bug #1340011 reported by Formerly Kevin Yin, now disabled on 2014-07-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

To reproduce:
Draw a rectangle.
Choose the select tool.
Resize the rectangle by dragging the arrow, holding down the mouse key (don't let go!)
Press alt. Note that when it claims to be resizing to 100%, it's doing nothing of the sort.

Seen on Inkscape 0.91pre1 on Windows 8.1. Not seen on 0.48.4 on Windows 8.1.

Also seen with control-snapping rotation at 0 degrees.

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r13449 on OS X 10.7.5

Based on tests with archived builds (same OS):
- not reproduced with rev <= 13332
- reproduced with rev >= 13333
the regression seems related to changes in revision 13333:
“Fix bounding box cache issues in general, and prevent the selector tool from updating anything in case of identity affines (which prevents the bounding box from being invalidated)”
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/13333>

tags: added: selection transformations
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.91
status: New → Confirmed
su_v (suv-lp) wrote :

@Diederick - this report possibly is another unintended side effect of the changes in r13333 ("Fix bounding box cache issues in general, and prevent the selector tool from updating anything in case of identity affines"). Would you mind taking a closer look?

Fixed again as of rev. 13450. It looks lp:1256597 is not being affected, as far as I can tell

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers