trunk/experimental: crash on open filter editor after blurring an object

Bug #1328152 reported by Liam P. White on 2014-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

Steps to reproduce:

1) launch inkscape with default prefs
2) draw rectangle
3) open Fill&Stroke and blur the rectangle slightly
4) open Filter Editor

—> crash

Program received signal SIGSEGV, Segmentation fault.
0x00000000009e2ddd in Inkscape::XML::SignalObserver::set (this=0x4b600c0, o=0x0) at ../../src/xml/helper-observer.cpp:18
18 _oldsel->getRepr()->removeObserver(*this);

Backtrace attached.

Liam P. White (liampwhite) wrote :
su_v (suv-lp) on 2014-06-09
tags: added: crash
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.91
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 13415.

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :

Also reproduced on Crunchbang Waldorf, Inkscape trunk revision 13416. Same backtrace as in comment #1.

Changed in inkscape:
status: Confirmed → Triaged
Johan Engelen (johanengelen) wrote :

fixed in rev. 13426

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
status: Triaged → Fix Committed
Johan Engelen (johanengelen) wrote :

Thanks for the bug report Liam.

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers