crash after copy

Bug #1328079 reported by Elad on 2014-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Mc

Bug Description

inkscape crashes when selecting and copying an element from the attached file.

>>test env:
win8x64;
inkscape 0.48.4

>>steps:
open attached file and try to copy the "thumbs up" element.

>>actual:
inkscape crashes.

>>Attached:
1. crashing file.
 2. .dmp: can be found here https://www.dropbox.com/s/0hky7t0qcjlut82/inkscape%20%282%29.DMP (139mb)

Elad (elads-shoham) wrote :

on further inspection seems that copying "vine" logo (from the attached file) causes the crash.

jazzynico (jazzynico) on 2014-07-02
tags: added: crash
Changed in inkscape:
importance: Undecided → High
jazzynico (jazzynico) wrote :

Confirmed on Crunchbang Waldorf, Inkscape 0.48.3.1 and trunk revision 13445.
Inkscape doesn't really crash, but is frozen until I kill the process.

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :

Attached is a reduced test file, with the affected rectangle and its defs.

jazzynico (jazzynico) wrote :

@Elad - One gradient definition is linked to itself, creating an infinite recursion:
----
    <linearGradient
       x1="100"
       x2="100"
       gradientUnits="userSpaceOnUse"
       xlink:href="#a-3"
       y2="200"
       id="a-3">
----

As far as I can tell, it isn't a valid definition.
Could you please tell us if parts of the drawing were imported from an external tool or if the file was hand-edited?

As for the report itself, it is currently marked "private". Since the issue can be reproduced with the reduced test file I've attached comment #4, would you accept if I delete your original attachment and mark the report "public" so that members of the bug team can see it? (you can also remove the dropbox file).

Changed in inkscape:
importance: High → Medium
status: Confirmed → Incomplete
Elad (elads-shoham) wrote :

@jazzynico
1. the whole logo file was imported from an open source image bank (I don't know how it was made).
2. sure, delete and change permissions as you see fit.

su_v (suv-lp) wrote :

Original file removed, information type changed to 'Public' afterwards.

information type: Private Security → Public
Changed in inkscape:
status: Incomplete → Confirmed
su_v (suv-lp) wrote :

Also reproduces with Inkscape 0.91+devel r14411, despite fixes for circular references in rev 14245:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14245

Mc (mc...) wrote :

pushed to r 14412

Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Confirmed → Fix Committed
su_v (suv-lp) on 2015-10-14
Changed in inkscape:
milestone: none → 0.92
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers