Trunk PPA FTBFS in Utopic. Missing Build-Depends: libpoppler-private-dev

Bug #1327232 reported by Alex Valavanis on 2014-06-06
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Alex Valavanis

Bug Description

FYI: Build failure seen in Ubuntu Utopic:

In file included from ../../src/extension/internal/pdfinput/svg-builder.cpp:22:0:
../../src/extension/internal/pdfinput/svg-builder.h:31:23: fatal error: CharTypes.h: No such file or directory
 #include "CharTypes.h"
                       ^
compilation terminated.
  CXX extension/internal/pdfinput/pdf-parser.o
In file included from ../../src/extension/internal/pdfinput/pdf-parser.cpp:34:0:
../../src/extension/internal/pdfinput/svg-builder.h:31:23: fatal error: CharTypes.h: No such file or directory
 #include "CharTypes.h"
                       ^
compilation terminated.
Makefile:8040: recipe for target 'extension/internal/pdfinput/svg-builder.o' failed

https://launchpadlibrarian.net/177044654/buildlog_ubuntu-utopic-i386.inkscape-trunk_1%3A0.48%2Bdevel%2B13408%2B47~ubuntu14.10.1_FAILEDTOBUILD.txt.gz

This is probably caused by the recent change in the Ubuntu Poppler source package:

poppler (0.26.0-1ubuntu2) utopic; urgency=medium

  * Don't have libpoppler-dev depend on libpoppler-private-dev. If a package
    needs this to build then it should Build-Depend on libpoppler-private-dev
    directly. (LP: #1325174)
 -- Iain Lane <email address hidden> Thu, 05 Jun 2014 11:01:06 +0100

It can be fixed by adding a build-dependency to libpoppler-private-dev in debian/control

tags: added: build
Changed in inkscape:
status: Triaged → Fix Released
assignee: nobody → Alex Valavanis (valavanisalex)
Alex Valavanis (valavanisalex) wrote :

Backported to stable packaging (r31)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers