Object clipped by cloned shape missing selection cue

Bug #1322940 reported by Liam P. White on 2014-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

Bug affects cloned rects, cloned stars, and cloned ellipses.

Steps to reproduce:

1. Draw one of the aforementioned shapes on the canvas.
2. Draw a short path.
3. Clone the shape.
4. Apply the clone as a clipping path to the object.

In the select tool, the selection bounding box and arrows around the object disappear. In the node tool and other shape tools, a selection cue is not seen.

Related bug #1005085

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r13388 on OS X 10.7.5.

Tests with archived builds: reproduced with rev >= 12005 (earlier builds showed arrows and sel cues, but didn't update the visual bbox as expected).

tags: added: regression
su_v (suv-lp) wrote :

Handles and sel cue reappear e.g. after toggling layer visibility off/on, or nudging the selection (which is still active) with the arrow keys.

Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.91
status: New → Triaged
importance: Low → Medium
Alvin Penner (apenner) wrote :

attached is a patch for this bug, based on rev 13446. It implements a fix similar to that for Bug 1005085.
As usual, any testing would be welcome.

Alvin Penner (apenner) wrote :

fix committed to rev 13448

Changed in inkscape:
status: Triaged → Fix Committed
assignee: nobody → Alvin Penner (apenner)
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers