[win64] GTK file picker crashes on choose

Bug #1322889 reported by Liam P. White on 2014-05-24
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
Inkscape Devlibs for Windows 64-bit
Undecided
Unassigned

Bug Description

Removing/commenting out these lines in the Inkscape source file "src/file.cpp" fixes it:

551: delete openDialogInstance;
561: delete openDialogInstance;

900: delete saveDialog;
911: delete saveDialog;

1298: delete importDialogInstance;
1309: delete importDialogInstance;

summary: - GTK file picker crashes on choose
+ [win64] GTK file picker crashes on choose
su_v (suv-lp) on 2014-05-24
tags: added: win64
su_v (suv-lp) wrote :
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: New → Confirmed
jazzynico (jazzynico) wrote :

Confirmed on WIndows 8.1, Inkscape 0.91 (64bit, 7zip package).

Changed in inkscape:
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

Still affecting win64 users (I can't test for now)?

Changed in inkscape:
milestone: 0.92 → 0.92.1
su_v (suv-lp) wrote :

JazzyNico wrote:
> Still affecting win64 users (I can't test for now)?

Crash with GTK+ dialogs not reproduced with Inkscape 0.92.0 r15299 (64bit, MSI) on Windows 10: renders preview of selected image (tested with SVG, PNG, GIF, BMP, TIF, JPG) and loads selected file ok.

Alvin Penner (apenner) wrote :

crash reproduced on Windows 10, Inkscape 0.92+devel 15423

if I use the GTK dialog to open a file, I get the attached popup error message, followed by this DOS output

C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape>inkscape

(inkscape.exe:1080): Gtk-WARNING **: Could not find the icon 'object-visible-ltr'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases

(inkscape.exe:1080): GLib-GIO-ERROR **: No GSettings schemas are installed on the system

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

Gtk-Message (recursed): GtkDialog mapped without a transient parent. This is discouraged.

Alvin Penner (apenner) wrote :

forgot this

su_v (suv-lp) wrote :

Alvin Penner wrote:
> (inkscape.exe:1080): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
>
> Emergency save activated!

This is likely a packaging issue with GTK3 on Windows (Inkscape trunk uses GTK3, on all platforms), and probably best tracked separately.

Alvin Penner (apenner) wrote :
Download full text (8.1 KiB)

running Windows 10, Inkscape 0.92+devel 15423, backtrace attached:

Program received signal SIGTRAP, Trace/breakpoint trap.
0x0000000000ec31fb in _g_log_abort (breakpoint=1) at gmessages.c:324
324 gmessages.c: No such file or directory.
(gdb) bt
#0 0x0000000000ec31fb in _g_log_abort (breakpoint=1) at gmessages.c:324
#1 g_logv (log_domain=0x25b5abc <__func__.14455+252> "GLib-GIO", log_level=G_LOG_LEVEL_ERROR, format=<optimized out>,
    args=<optimized out>) at gmessages.c:1077
#2 0x0000000000ec32d8 in g_log (log_domain=0xffffffff <error: Cannot access memory at address 0xffffffff>,
    log_domain@entry=0x25b5abc <__func__.14455+252> "GLib-GIO", log_level=0, log_level@entry=G_LOG_LEVEL_ERROR,
    format=0x1 <error: Cannot access memory at address 0x1>,
    format@entry=0x25b5fd8 <__func__.14455+1560> "No GSettings schemas are installed on the system") at gmessages.c:1118
#3 0x000000000252f328 in g_settings_set_property (object=<optimized out>, prop_id=<optimized out>, value=0x66dd40,
    pspec=<optimized out>) at gsettings.c:585
#4 0x0000000063a4cd81 in object_set_property (nqueue=0x11f00610, value=<optimized out>, pspec=0x13084800, object=0x1305d4a0)
    at gobject.c:1421
#5 g_object_new_internal (class=0x1324a220, params=0x66dea0, n_params=1) at gobject.c:1815
#6 0x0000000063a4f3a2 in g_object_new_valist (object_type=317862064, object_type@entry=106752144,
    first_property_name=first_property_name@entry=0x25b5e2c <__func__.14455+1132> "schema-id", var_args=0x66e1ec "",
    var_args@entry=0x66e050 "azo\001") at gobject.c:2040
#7 0x0000000063a4f40e in g_object_new (object_type=106752144, first_property_name=0x25b5e2c <__func__.14455+1132> "schema-id")
    at gobject.c:1624
#8 0x00000000016bbc9d in _gtk_file_chooser_get_settings_for_widget ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#9 0x00000000016c95bc in gtk_file_chooser_widget_get_default_size ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#10 0x00000000016b7671 in _gtk_file_chooser_embed_get_default_size ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#11 0x00000000016b5fb5 in file_chooser_widget_default_size_changed ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#12 0x0000000063a4732c in g_closure_invoke (closure=0x12f22ca0, return_value=return_value@entry=0x0, n_param_values=1,
    param_values=param_values@entry=0x66e470, invocation_hint=invocation_hint@entry=0x66e3d0) at gclosure.c:804
#13 0x0000000063a5a612 in signal_emit_unlocked_R (node=<optimized out>, node@entry=0x12f1ed50, detail=0,
    instance=instance@entry=0x12f234f0, emission_return=emission_return@entry=0x0,
    instance_and_params=instance_and_params@entry=0x66e470) at gsignal.c:3629
#14 0x0000000063a63f5d in g_signal_emit_valist (instance=<optimized out>, instance@entry=0x12f234f0,
    signal_id=signal_id@entry=358, detail=106858048, detail@entry=0, var_args=<optimized out>, var_args@entry=0x66e6d0 "@+^\006")
    at gsignal.c:3385
#15 0x0000000063a64634 in g_signal_emit_by_name (instance=0x12f234f0,
    detailed_signal=0x19ca3b5 <__func__.3830...

Read more...

su_v (suv-lp) wrote :

Proposing to close as 'Fix Released' with milestone 0.92.0 - it works as expected with Inkscape 0.92.0 r15299 (64bit, MSI) (tested on Windows 10, see comment 4).

The crash with trunk (GTK3) mentioned in comments 5-8 (likely due to missing - i.e. not installed (devlibs), or not found at runtime (env) - glib schemas) has been filed separately as
* Bug #1663884 “crash when attempting to use gtk open dialog in Inkscape trunk, 64 bit, Windows 10”
  https://bugs.launchpad.net/inkscape/+bug/1663884

jazzynico (jazzynico) on 2017-02-13
Changed in inkscape:
milestone: 0.92.1 → 0.92
status: Triaged → Fix Released
Changed in inkscape-devlibs64:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments