The Layers window doesn't track groups, doesn't display every object

Bug #1316398 reported by Jeff B on 2014-05-06
This bug report is a duplicate of:  Bug #171995: Layer and Object Manager. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

I'm coming from an Adobe Illustrator background, and I really like Inkscape but one feature I'm really missing is the Layers window. In Illustrator, every object is displayed within the Layers window. I can navigate, organize, group, arrange, etc... items, their relationships, and hierarchal layout in Illustrator's Layers window.

The Layers window in Inkscape is a little confusing (to me anyway). From what I can tell, Inkscape has groups, and it has layers, but they aren't the same and are treated differently. I suggest moving away from this. Call them groups... or call them layers... but they would be the same thing.

For example, if I create two rectangles, then group them, nothing is displayed in the Layers window. I'd like the Layers window to display every object, in an object tree/hierarchal tree, and be able to move a parent object (and its children) up, down, and in and out.

So for example, if I create a new document, add two rectangles, then group them, I'd like the Layers window to display something like:

Group 1
    Rectangle 2
    Rectangle 1

I'd like to be able to rename the object from the Layers window, and I'd like to be able to drag and drop an item (and its children) in and out of groups.

Thanks,

Jeff

Related branches

Liam P. White (liampwhite) wrote :
tags: added: layers
su_v (suv-lp) wrote :

Basically a duplicate of bug #171995 ("Layer and Object Manager like in Adobe Illustrator, so you can easily gain
access to objects.") - do we need to track this in yet a separate report?

Changed in inkscape:
importance: Undecided → Wishlist
Qantas94Heavy (qantas94heavy) wrote :

Agree this is basically bug #171995 -- there is now an Objects panel which does what you are asking for.

Changed in inkscape:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers