trunk: incorrect rendering of circle segment (rev >= 12921)

Bug #1312333 reported by su_v on 2014-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

The two circle segments in the attached test case render incorrectly in trunk rev >= 12921.

Example SVG snippet:

    <path
       sodipodi:end="1.8656599"
       sodipodi:start="1.8656761"
       d="m 744.45079,590.71403 a 3.25,3.25 0 1 1 5e-5,10e-6 l 0.94448,-3.10973 z"
       sodipodi:ry="3.25"
       sodipodi:rx="3.25"
       sodipodi:cy="587.60431"
       sodipodi:cx="745.39532"
       id="path3375"
       style="display:inline;fill:#b1ff45;fill-opacity:1;stroke:none"
       sodipodi:type="arc" />

Originally reported here:
<http://bugs.siduction.org/issues/1606>

Reproduced on OS X 10.7.5 with 0.48+devel rev >= 12921:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12921>

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

Bitmap export with r13301 (90 dpi)

su_v (suv-lp) wrote :

Bitmap export with r12920 (90 dpi)

jazzynico (jazzynico) wrote :

Reproduced on Crunchbang Waldorf, Inkscape trunk revision 13302.

Changed in inkscape:
status: New → Triaged
su_v (suv-lp) on 2014-04-26
Changed in inkscape:
importance: Undecided → Medium
Alvin Penner (apenner) wrote :

there is a discrepancy between the way that perfect circles are handled, compared to the way in which almost circles (like 359.9 degree arcs) are handled.

looks like it should not be hard to fix, I'll look into it.

Alvin Penner (apenner) wrote :

fix committed to rev 13327

ellipse code modified to not allow individual arc segment greater than 90 degrees.

Changed in inkscape:
status: Triaged → Fix Committed
su_v (suv-lp) on 2014-04-30
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers