resize page to drawing resets unit to px (rev >= 12554)

Bug #1310787 reported by Sam Petrocelli on 2014-04-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Alvin Penner

Bug Description

File -> Document Properties. In "Custom Size" box area select "mm" in "units" combobox. Click the "resize page to drawing or selection" and the units combobox resets to "px" and the page width/height dimensions also reset to "px" scale.

I am running Fedora 20 with Inkscape 0.48+devel r13293.

Alvin Penner (apenner) wrote :

- not reproduced on Windows XP, Inkscape rev 13288
- not reproduced on Windows 7, Inkscape 0.48.4

su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.48.4 r9939
- reproduced with Inkscape 0.48+devel r13294

tags: added: units
tags: added: regression
Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.91
status: New → Confirmed
Alvin Penner (apenner) wrote :

sorry about that, now I am reproducing it as well on rev 13288. I had forgotten to actually select an object to resize to, doh.

description: updated
su_v (suv-lp) wrote :

Based on tests with archived builds on OS X 10.7.5:
- not reproduced with rev <= 12552,
- reproduced with rev >= 12555;
the regression was likely introduced with the merge of the unit improvement branch in r12554:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12554>

summary: - resize page to drawing resets unit to px
+ resize page to drawing resets unit to px (rev >= 12554)
Changed in inkscape:
status: Confirmed → Triaged
Alvin Penner (apenner) wrote :

fix committed to rev 13590

Changed in inkscape:
status: Triaged → Fix Committed
su_v (suv-lp) on 2014-10-12
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
su_v (suv-lp) wrote :

@Alvin - in revision 13715 <lp:inkscape> you modified the fix applied in rev 13590 in <lp:inkscape> for this report (bug #1310787) - does this fix need to be backported to the stable release branch 0.91.x <lp:inkscape/0.91.x> too? Can - or should - it be considered for backporting at all?

Alvin Penner (apenner) wrote :

good question, I think the answer is yes, it would be a good idea to backport the new fix. I ran into this by accident. I was using the file default.svg from trunk, which is different than the previous default.svg file, because everything is now in mm. This file has a minor inconsistency in that the variable 'units' in the namedview section is missing. That fact that it is missing is not important because it is redundant and should be removed anyways. But I was using this variable and was mis-identifying the units because of it. So I switched to using the units obtained from the height specification in root. This is foolproof as far as I can tell. Anyways the same comment applies to 91.x as well. I downloaded default_mm.svg from .91x and encountered the same issue, so it would be worthwhile to backport it there as well.

su_v (suv-lp) wrote :

Second part of the fix (revision 13715) needs to be backported to 0.91.x, setting milestone to 0.92 for now.

Changed in inkscape:
milestone: 0.91 → 0.92
tags: added: backport-proposed
ScislaC (scislac) wrote :

fix backported in 0.91.x r13663

Changed in inkscape:
milestone: 0.92 → 0.91
su_v (suv-lp) on 2014-11-27
tags: removed: backport-proposed
su_v (suv-lp) wrote :

Follow-up report (regression related to rev 13715):
- Bug #1419122 ""resize page to selection" broken in 0.91 with width="100%", height="100%"”
  https://bugs.launchpad.net/inkscape/+bug/1419122

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers