Adding/Removing embedded scripts cause crash

Bug #1302079 reported by FirasH on 2014-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

- Basic description:

Adding/Removing more embedded script in a row cause Inkscape crash.

- Steps to reproduce:

0) Create a new document
1) Go to File > Document Properties > Scripting > Embedded scripts
2) Click on the green "+" to add a "Script id"
3) Select the script created in step 2 and press the red "-" to delete it
4) Repeat step 2 and 3 until Inkscape crashes

The number of times you need to repeat step 4 are not always the same.

- System information:

Inkscape version: 0.48+devel (rev 13258)
OS: openSUSE 13.1 (x86_64)

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r13249 on OS X 10.7.5.

tags: added: crash javascript ui
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
su_v (suv-lp) wrote :

Backtraces are not consistent - attached file contains 3 variations.

su_v (suv-lp) wrote :
Changed in inkscape:
milestone: none → 0.91
Johan Engelen (johanengelen) wrote :

Should be fixed in rev. 13265 (couldn't reproduce it after)

su_v (suv-lp) wrote :

FIx confirmed - not reproduced with r13266 on OS X 10.7.5 either.

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
status: Confirmed → Fix Committed
FirasH (firashanife) wrote :

Cannot reproduce anymore with r13266 on openSUSE 13.1

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers