Clone Original Path gets clip/mask of path instead of path

Bug #1293979 reported by Liam P. White on 2014-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Liam P. White

Bug Description

Clone Original Path returns the clip path/mask of the object it links to, instead of the path.

Steps to reproduce:
1. Launch trunk
2. Draw a short path with the pen tool
3. Draw a clip path and clip the item
4. Copy the item
5. Draw a new path, and add Clone Original Path path effect
6. Paste the item on the clipboard using the "Link" parameter.

Expected result: Clone Original Path copies the linked path.
Actual result: The clip path/mask of the linked path is returned instead.

Bug can not be reproduced if steps 3 and 4 are reversed (path effect works as expected).

Additional information for developers:
The method ClipboardManager::getShapeOrTextObjectId (seen on live_effects/parameter/path.cpp:452) is probably to blame for this.

su_v (suv-lp) wrote :

Reproduced on OS X 10.7.5 with Inkscape 0.48+devel r10875 (archived build, initial commit of new 'Clone original' LPE was in r10874), and with current trunk r13163.

tags: added: clipping livepatheffects
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
tags: added: clipboard
jazzynico (jazzynico) wrote :

Also confirmed on Crunchbang Waldorf, Inkscape trunk revision 13163.

Note that Clone Original Path copies the linked path when the clip is a path. When the clip is an object (eg a rectangle) the LPE copies the path without the clip instead.

Changed in inkscape:
status: Confirmed → Triaged
Liam P. White (liampwhite) wrote :

Fix seems simple enough--ignore the <defs> of the SPDocument created by the clipboard manager. Needs testing for unintended side effects.

Changed in inkscape:
assignee: nobody → Liam P. White (inkscapebrony)
Changed in inkscape:
status: Triaged → In Progress
Liam P. White (liampwhite) wrote :

Fix committed to lp:inkscape, r13478.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) on 2014-07-29
Changed in inkscape:
milestone: none → 0.91
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers