Wrong page size send to printer

Bug #1289733 reported by Kador on 2014-03-08
This bug report is a duplicate of:  Bug #630635: Print page size is incorrect. Edit Remove
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
cybercow

Bug Description

Hello

I am printing on A4 paper. I select A4 size in the page settings, but it seems that the printer driver gets a dimensional information (the actual page size in mm I guess) and does not get the "A4" information. It sees the page size as "personnalized", not A4.

I can print if I force the A4 size in the printer driver, but I need to do it each time.

Not severe, but annoying.

Printer : Canon 8150
Inkspace 0.48.4
Windows 7/64

Thanks

su_v (suv-lp) on 2014-03-08
tags: added: printing win32
cybercow (cybercow) wrote :

I am not sure if thats a bug. It sounds more like a feature you would like to have. What happens if you don't force the paper format to A4 in the printer driver? I would expect that the print fits perfect on the A4 paper. May the edges are cut off but thats becouse the most printers cant print the paper tho the edges und let some mm white.

Changed in inkscape:
assignee: nobody → cybercow (cybercow)
Kador (kador) wrote :

Well, for me it's a bug, since I am editing an A4 page, printing an A4 page, and the printer does not get the right information and refuses to print (because the paper trailer is configured for A4 paper, of course). This printer CAN print full pages, but it seems that the information that it gets is the page size in mm, not the format. I'm can't verify the data flow of course, but the result is clear and annoying.

Ralph van Etten (ralph-q) wrote :

I have the same problem.

If I set the document properties in Inkscape to A4 and then try to print the Paper size in the Print dialog is set to "custom" (and is unchangeable). My printer refuses to print this because it is not A4 paper.

A couple of versions ago it worked but after an update a while ago (can't remember which one but at least a year ago) these problems started.

I can add screenshots of the problem if you want them.

Also, it seems this is the same bug: https://bugs.launchpad.net/inkscape/+bug/630635 especially GB (https://bugs.launchpad.net/inkscape/+bug/630635/comments/3)

OS: Linux (Debian)
Inkscape: Inkscape 0.48.4 r9939
Printer: Konica Minolta 2430DL

jazzynico (jazzynico) wrote :

ralph-q> Also, it seems this is the same bug

Confirmed. I'm marking the report as duplicate of the older one.
Thanks for your help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers