Crash on some lpe whith path parameters at Ctrl+Z

Bug #1287996 reported by Jabiertxof on 2014-03-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Jabiertxof

Bug Description

Steps to reproduce:
Start inkscape
Create a ellipse, convert to path.
Create another ellipse, convert or not to path -both crash-,
Group both.
Apply Bend or Envelope
Move a path parameter -the path, a node-.
Whith path parameter active...
Ctrl-Z tree times (maybe is important do it fast).
Crash.

http://pastebin.com/6Ng4SEeM

Sometimes have another backtrace, but i coulden`t reproduce in a few oportunities.

su_v (suv-lp) on 2014-03-05
tags: added: livepatheffects undo
su_v (suv-lp) on 2014-03-05
tags: added: crash
Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

Crash not reproduced with trunk based on provided steps, using
- on Ubuntu 13.10 (VM, 64bit), r13076 (PPA), r13084 (local build)
- on OS X 10.7.5 (64bit), r13113 (local build)

su_v (suv-lp) wrote :

Based on comments in earlier reports a known issue:
“It seems undoing lpe param changes on group lpes does not work. I tried with lpe-bend for example, and it crashes.”
<https://bugs.launchpad.net/inkscape/+bug/365903/comments/9>

Possibly related earlier reports:
Bug #365903 “lpe-knot for groups” comments 8+9
Bug #456503 “Undo crash and von Koch LPE”
Bug #484057 “adding path effect not properly recorded in undo history => crash”
Bug #518741 “Undoing an "envelope" transformation triggers a segfault”
Bug #540591 “Undo LPE editing in node tool crashes”
Bug #1075447 ”some path effects lead to empty elements in the undo history”

Jabiertxof (jabiertxof) wrote :

Still happans in a clean trunk of a Debian semi-stable 64

description: updated
Jabiertxof (jabiertxof) wrote :

Any body have this problem? If yes i mark as duplicate of 456503

Jabiertxof (jabiertxof) on 2014-03-05
description: updated
description: updated
Jabiertxof (jabiertxof) wrote :

the fix in bug #540591 also fix this

Jabiertxof (jabiertxof) wrote :

Fixed on r.14975

Changed in inkscape:
status: New → Fix Committed
jazzynico (jazzynico) on 2016-06-11
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
milestone: none → 0.92
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers