Hairline strokes (linewidth 0) in imported PDFs are not visible

Bug #1283537 reported by Luiz Angelo Daros de Luca on 2014-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski

Bug Description

Hello,

All charts from Libreoffice, when exported to PDF and imported in inkscape, gets not axes or grid lines.
The inkscape preview display (when I'm selecting the page) even shows the line.

I'll attach an PDF file.

Alvin Penner (apenner) wrote :

- reproduced on Windows 7, Inkscape 0.48.4

- not reproduced on Windows XP, Inkscape development rev 13031, result attached.
- which OS and Inkscape are you running? Depending somewhat on your OS, you may be able to try a more recent development version of Inkscape.

I'm using 0.48.4 r9939 on win7.

I just tested the 0.48+devel r13012 version and the problem is solved. Thanks.

I just hope inkscape releases a stable version soon. 0.48.4 is getting old. :-)

Alvin Penner (apenner) wrote :

good to hear, in that case I'll mark this as Fix Committed, without knowing exactly when this was fixed.

wrt to a new release, I know a new release is in the works, but not sure of the precise schedule:

http://inkscape.13.x6.nabble.com/Bug-Hunt-for-0-91-td4969141.html

Changed in inkscape:
status: New → Fix Committed
su_v (suv-lp) wrote :

Based on tests with archived builds (reproduced with rev <= 11361, not reproduced with rev >= 11364), this was fixed in r11364:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11364>

See also:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.user/14539>

Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
importance: Undecided → Medium
milestone: none → 0.91
tags: added: importing pdf
su_v (suv-lp) on 2014-02-23
tags: added: backport-proposed

Hello,

I found another file that reproduces the problem even with recent inkscape devel version r13012.

The graph on page 2 (and others). Also, the table on page 4 is imported with different line width while in adobe reader, there is no visual difference.

Krzysztof Kosinski (tweenk) wrote :

Backported to stable in r10015

tags: removed: backport-proposed
Changed in inkscape:
milestone: 0.91 → 0.48.5
Alvin Penner (apenner) wrote :

    The problem encountered in the file Artigo VII CITENEL is somewhat similar to the problem originally fixed for file Graph LO.pdf, but it is more complex this time. In the original problem, fixed in rev 11364, the problem was just that the linewidth did not have a default value. Now it has a default value of 1. The new problem shown in file Artigo VII CITENEL, page 2, graph called Tempo, is that the linewidth is not initiallized, and also that it is embedded in a transformed group with a scale factor of 0.014 roughly, so the effective linewidth is 0.014 even after initiallization, which is not easily visible. Typical group element is shown below.
    This will be much more difficult to solve than the original bug report.

...................................................

<g id="g3572" transform="matrix(0.014108,0,0,-0.0136098,303.55994,770)">
    <g id="g3574" transform="translate(16539,1432)">
        <path d="M 0,0 -13336,0"
              style="fill:none;stroke:#b4b4b4;stroke-width:1;stroke-linecap:square;stroke-linejoin:miter;
              stroke-miterlimit:10;stroke-opacity:1;stroke-dasharray:none"
              id="path3576"
              inkscape:connector-curvature="0" />
    </g>
</g>

Alvin Penner (apenner) on 2014-03-09
Changed in inkscape:
status: Fix Committed → Confirmed
assignee: Alvin Penner (apenner) → nobody
su_v (suv-lp) on 2014-03-09
Changed in inkscape:
milestone: 0.48.5 → none
Krzysztof Kosinski (tweenk) wrote :

What is the correct output in this case? Should the default linewidth ignore transforms (e.g. the linewidth should default to 1 * fabs(descriminant of current transform)?

Alvin Penner (apenner) wrote :

not sure what the answer is, the only thing that is clear is that the Inkscape result is not consistent with Adobe Reader. Adobe seems to produce a default linewidth that is visually 1 px, regardless of whatever transforms may be present.

Krzysztof Kosinski (tweenk) wrote :

I checked the PDF. This behavior is resolution-dependent, so it can't be replicated exactly. As an approximation, we can convert such lines to 1px strokes.

See also: bug #448286

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
status: Confirmed → Fix Committed
Krzysztof Kosinski (tweenk) wrote :

Partial fix (hairline strokes rendered as 1px lines compensated for transform) in trunk r13143.
Backported to stable in r10016.

summary: - Grid and axes lines in charts are not imported from Libreoffice PDF file
+ Hairline strokes (linewidth 0) in imported PDFs are not visible
Changed in inkscape:
milestone: none → 0.48.5
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers