dbus API documentation: broken whitespace formatting with recent libxml2

Bug #1282045 reported by su_v on 2014-02-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Tomasz Boczkowski

Bug Description

With current versions of dependencies (most relevant are likely libxml2, libxslt, xmlto), the generated dbus API documention loses important whitespace:

Not reproduced with
- libxml2 @2.8.0_100 (active)
- libxslt @1.1.27_100 (active)
- xmlto @0.0.25_0 (active)
installed (on OS X 10.7.5).

Reproduced with
- libxml2 @2.9.1_0 (active)
- libxslt @1.1.28_0 (active)
- xmlto @0.0.25_1 (active)
installed (on OS X 10.7.5)

First noticed when browsing Ryan Lerch's online version (generated on Fedora):
<http://ryanlerch.org/inkscape-dbus-documentation/>
compared to an earlier version I had uploaded to Dropbox:
<http://dl.dropboxusercontent.com/u/65084033/devel/dbus/doc/inkscapeDbusRef.html>

Similar changes in whitespace handling with recent libxml2 >= 2.9 affect Inkscape elsewhere too (bug #1204732). It's still unclear to me whether this an upstream bug, or a planned upstream change which requires that all clients of the library have to adapt to?

Related branches

su_v (suv-lp) wrote :

Current doc (xml) created with libxml2 2.8.0

su_v (suv-lp) wrote :

current doc (xml) created with libxml2 2.9.1

Attached patch fixes whitespace formatting in dbus documentation. It substitutes the definition of variable "spaces". Former relied on xml:whitespace attribute in xsl:variable definition.

Ignoring xml:whitespace in xsl:variable definition looks like libxml 2.9.0 regression.

Changed in inkscape:
assignee: nobody → Tomasz Boczkowski (penginsbacon)
su_v (suv-lp) wrote :

Patch tested successfully on OS X 10.7.5 with libxml2 2.7.8, 2.8.0 and 2.9.1.

Changed in inkscape:
importance: Undecided → Low
status: New → In Progress
su_v (suv-lp) wrote :

Thx for the patch - committed in rev 13066.

Changed in inkscape:
milestone: none → 0.91
status: In Progress → Fix Committed
su_v (suv-lp) on 2014-05-06
tags: added: dbusapi
removed: dbus
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers