flowed text appearance changes depending on default document units

Bug #1278561 reported by Alvin Penner on 2014-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

- Windows XP, Inkscape rev 12991
- load the attached file, with some normal text and some flowed text
- change the default units from px to mm, nothing happens, no change.
- change the default units from mm to px, flowed text becomes about 3 times smaller.
- change the default units from px to mm, flowed text recovers its original size.
- change the default units from mm to cm, flowed text disappears.
- change the default units from cm to mm, flowed text recovers its original size.

- in all of this, the normal text is unchanged.

- as far as I can tell, the rule seems to be:
1. ignore the first change of units, no matter what it is
2. on subsequent changes of units, if the new unit is smaller than the first new value, then reduce the size
3. if the new unit is larger than the first new value, then refuse to show the text, possibly because it does not fit the box?

Alvin Penner (apenner) wrote :
su_v (suv-lp) wrote :

On OS X 10.7.5, with default (new) prefs and en_US locale:
- not reproduced with 0.48.4 r10009
- not reproduced with 0.48+devel rev <= 12552
- incorrect scaling and positioning with 0.48+devel rev >= 12555

The effects on my system though are different than described by Alvin, for each of the steps:
- the regression is already triggered on first unit change
- 'px' -> 'mm': flowed text is offset, flowRegion scaled up, font size the same
- 'mm' -> 'px': flowed text reverts to old position, flowRegion back to original size
- 'px' -> 'mm': same as in step 2
- 'mm' -> 'cm': flowed text is displaced (outside page), flowRegion scaled up even larger, but font size stays the same
- 'px' -> 'm' -> 'px': text disappears (truncated: flowRegion repositioned to SVG origin, scaled to a very tiny rect)
- (…)

--
updated version of comment #2, fixes typo

tags: added: regression text units viewbox
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.91
status: New → Confirmed
ScislaC (scislac) on 2014-08-16
tags: added: blocker
Alvin Penner (apenner) wrote :

fix committed to rev 13578

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2014-10-03
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
tags: removed: blocker
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments