trunk: stretching a hor/ver line offsets it (rev >= 12964)

Bug #1275077 reported by su_v on 2014-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

Steps to reproduce:
1) launch trunk with default (new) prefs
2) draw a horizontal line, set a wide stroke
3) turn off stroke scaling
4) stretch the line horizontally with the mouse

Expected result:
The line is extended horizontally, without vertical offset

Actual result:
The stretched (extended) line is vertically offset.

Notes:
- activating 'Snap cusp nodes, incl. rectangle corners' keeps the stretched line in the correct position, even if there is no other snap target visible (no grid, no guides, no other objects). Why?
- does not affect stretching with stroke scaling turned on.

Testing with archived builds on OS X:
- not reproduced with rev <= 12963,
- reproduced with rev >= 12964

su_v (suv-lp) on 2014-01-31
description: updated
su_v (suv-lp) on 2014-01-31
description: updated
Alvin Penner (apenner) wrote :

- confirmed on Inkscape rev 12991
- I'll look into it, it looks like I was focusing so much on stroke width scaling that I neglected to look at anything else.

Changed in inkscape:
status: New → Confirmed
Alvin Penner (apenner) wrote :

fix committed to rev 12993

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2014-02-01
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
milestone: 0.91 → none
status: Fix Committed → Fix Released
Kris (kris-degussem) on 2014-02-02
Changed in inkscape:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers