multiple selected nodes, transformations revert when moved (rev >= 9985)

Bug #1270989 reported by Cojnel
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Fix Released
Medium
Alexandru Roman

Bug Description

Tested with r12960 (default preferences) on linux mint 15 32bit.
It does not happen in v0.48.4 r9939.

Draw a path with at least 2 nodes,
pick the node tool,
select more than one node,
turn on show transformation handles,
make one transformation with a
scale/rotate or skew handle,
drag one of the selected nodes,
the nodes snap to the position
they had when they were first drawn.

If two or more transformation are performed,
then the nodes snap to the position they had
before the last transformation.

The center of rotation seams to keep the position
it got after the transformation when the nodes revert,
the same thing happens to the node handles.

Revision history for this message
su_v (suv-lp) wrote :

Reproduced with r12964 on OS X 10.7.5.

- also reproduced with oldest archived build on this computer (r10795),
- not reproduced with stable 0.48.4 (r10007)

tags: added: regression
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.91
status: New → Triaged
Revision history for this message
su_v (suv-lp) wrote :

Based on tests with really old archived builds (compiled 2010 on Mac OS X 10.5.8, run on OS X 10.7.5):
- not reproduced with 0.48+devel rev <= 9983,
- reproduced with 0.48+devel rev >= 9987;
it seems possible that this regression is related to the changes for in rev 9985:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/9987>
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/9985>

summary: - multiple selected nodes, transformations revert when moved
+ multiple selected nodes, transformations revert when moved (rev >= 9985)
Revision history for this message
Vladimir Savic (vladimir-firefly-savic) wrote :

Any progress on this? Is this a job for Johan?

su_v (suv-lp)
Changed in inkscape:
milestone: 0.91 → 0.92
Revision history for this message
su_v (suv-lp) wrote :

@Diederik - any chance you could take a look whether there's an easy fix for this bug?

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
Revision history for this message
Daniel (danieljabailey) wrote :

Still present on r14741

Revision history for this message
Pétery Tamás (lazur) wrote :

Still present in 0.92pre2 15127.

Duplicate report #1644605.

Revision history for this message
Mc (mc...) wrote :

fixed in r15435 by alexandru roman.

Changed in inkscape:
assignee: Diederik van Lierop (mail-diedenrezi) → Alexandru Roman (alexandru.roman)
milestone: 0.92 → 0.93
status: Triaged → Fix Committed
Revision history for this message
su_v (suv-lp) wrote :

Backport of lp:inkscape r15435 to 0.92.x tested successfully with lp:inkscape/0.92.x r15336 (on OS X 10.7.5).

tags: added: backport-proposed
Revision history for this message
Patrick Storz (ede123) wrote :
Changed in inkscape:
milestone: 0.93 → 0.92.2
tags: removed: backport-proposed
jazzynico (jazzynico)
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments