skew problem when the center of rotation is on a bounding box edge

Bug #1266499 reported by Cojnel on 2014-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

If the center of rotation is moved to a corner or side of the bounding box of
an object and a skew handle on the same side is dragged,
then the object gets skewed so that some or all the objects
x, y, width and height inputboxes on the tool controls bar show a value of 1 million.

1. turn on snapping for:
    "snap bounding box corners" and
    "snap an item's center of rotation".
2. draw a rectangle.
3. activate the selection tool.
4. select the rectangle and click on it once to show it's center of rotation.
5. drag the center of rotation so that it snaps to the bottom-left corner.
6. now drag the left skew handle,
   inkscape becomes unresponsive for a couple of seconds
   (at least on my machine, athlon 3800+ (single core)),
   notice that some or all of the x, y, w and h inputboxes show a value of 1 million,
   when i chose View > Zoom > Drawing,
   then at the bottom-right of the inkscape window to the left of the zoom level,
   the x or y coordinates show a value of 1-2 billion.

There have been 3 different outcomes when the skew handle was dragged:
#1
Most often some or all of the x, y, width or height inputboxes changes to 1,000,000.00 (1 million).

#2
Sometimes the object skews a fixed amount with the statusbar text saying:
"Skew: 45,00 (degrees symbol)",
if one continues to drag the skew handle then nothing happens.

#3
And rarely nothing happens.

The second and third outcomes seam to happen more often when skewing a path (at least when i tried it now).

Possible reason:
It seams to happen because the closer to for instance the left edge of a rectangle the center of rotation is moved,
the more the right edge will skew when the left skew handle is dragged.

When the center of rotation is on the left bounding box edge,
then the right side moves infinitely far, but since the maximum value seams to be 1 million it gets constrained.

I'm guessing that the maximum value is 1 million because that's the
largest values when one right clicks on the the x, y, w and h inputboxes.
Here's a previous bug report about it:
https://bugs.launchpad.net/inkscape/+bug/1255801

It happens in both:
v0.48.4 r9939
and r12881
on linux mint 15 cinnamon 32bit

Cojnel (cojnel) on 2014-01-06
description: updated
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.47, 0.48 and current trunk (r13008) on OS X 10.7.5.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed

This has been fixed as of rev. #13530

Thanks for reporting and triaging!

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
su_v (suv-lp) on 2014-08-23
Changed in inkscape:
milestone: none → 0.91
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers