Dotted lines associated with bbox are not visible if they overlap with a black object or background.

Bug #1266308 reported by Alvin Penner on 2014-01-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

- Inkscape rev 12851, Windows XP
- load attached file, set the bbox preference to be Geometric
- select the rectangle and note that the dashed bbox lines are not visible if they are inside the stroked region. The handles/arrows are visible regardless of where they are located.

Alvin Penner (apenner) wrote :
Alvin Penner (apenner) wrote :

- not reproduced in Inkscape 0.48.4, screenshot attached showing the dotted lines.

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk revision 12882 and 10568 (the oldest available version on my computer).
Not reproduced with 0.48.4.

Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.91
status: New → Triaged
tags: added: regression selection ui
su_v (suv-lp) wrote :

Not limited (or related) to geometric bounding box AFAIU: add a dark background, and the visual bounding box selection cue isn't visible either (no XOR anymore in trunk?).

su_v (suv-lp) wrote :

Also affects the frame drawn while dragging with the selection tool to create a selection: with trunk this frame is always drawn solid black, and no longer uses XOR colors as with current stable.

jazzynico (jazzynico) on 2014-01-06
summary: - dotted lines associated with geometric bbox are not visible if they
- overlap with the stroke
+ Dotted lines associated with bbox are not visible if they overlap with a
+ black object or background.
jazzynico (jazzynico) wrote :

Also affects rubberband selection (same SP_TYPE_CTRLRECT type).

Doesn't affect the selection cue when the "Tool>Selector>Per-object selection cue" preference is set to Mark (SP_TYPE_CTRL).

Alvin Penner (apenner) wrote :

- draw a rectangle with a dark fill, any color
- draw some text on top of it, or better, half on top and half not.
- deselect everything
- click on the text tool F8
- hover over the text, until a rectangle appears around the text
- previously this live rectangle would have been XOR'ed onto the background, now it is not, I guess it is just copied.

- as mentioned in comment 6, these types of objects appear to be of class SPCtrlRect, file src\display\sodipodi-ctrlrect.cpp. The code for this class was significantly rewritten in rev 10326. In particular, something called INK_COMPOSE was removed.

Alvin Penner (apenner) wrote :

the class SPCtrlRect is used for drawing live borders while dragging the mouse. Previously this was done using XOR drawing, the XOR command showing up in the macro INK_COMPOSE. This has been disabled previously in trunk since it belonged to libnr. In addition to this, cairo does not appear to support this kind of bitwise xor operation, see:

http://comments.gmane.org/gmane.comp.lib.cairo/1320

for this reason, and since it is essential that this rendering be done very quickly since it is occurring during a drag event, it was decided to do the outline using a very simple method of drawing two lines, one light, one dark. This appears to be somewhat similar to what Gimp does, but much simpler than their rubberband designs.

committed to rev 12936

Changed in inkscape:
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers