Alt D clears undo history even when nothing happens

Bug #1255367 reported by Formerly Kevin Yin, now disabled on 2013-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

Inkscape 0.48.4

To reproduce:
1. Do something. Open up the Undo History panel.
2. Ctrl Z.
3. Without selecting anything, press Alt+D.

Effects:
All the undone entries in the Undo History panel will disappear.

su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.4 on OS X 10.7.5.

(Alt+D has no affect without a selection, and with a selection, it creates a clone as expected, and discards undone edits because there is different change applied in the undo history).

tags: added: undo
jazzynico (jazzynico) wrote :

Not reproduced on Crunchbang Waldorf (a Debian stable based distro) with Inkscape 0.48.3.1.

Sorry, I think Node tool has to be active when you press Alt+D.

su_v (suv-lp) wrote :

> I think Node tool has to be active when you press Alt+D.

Not reproduced either (0.48.4 on OS X 10.7.5).

Reproduced on 0.48.4 on Xubuntu 13.04, running on VMware on original machine. But I'm the original reporter. Gif is for 0.48.4, Windows 7 on VMware. Original bug report was for Windows 7 on bare metal.

Anyway, just for you guys, I got a cool new piece of software called LICEcap. I don't know if it is actually safe, so I can't recommend it. However, it is useful.

In the gif at the end, I press Ctrl+Z to undo, then Alt+D at the time the Rectangle entry disappears in the Undo History. I've seen screen recording software that can handle keypresses as well, although I don't know of any free ones off the top of my head. Recommend me one? (trustworthiness is optional, because I can virtualize any sketchy software)

su_v (suv-lp) wrote :

Reproduced with 0.48.4 and current trunk r12832 if the mouse focus is on-canvas and not in the 'Undo History' dialog.

(I didn't reproduce because I used the keyboard shortcuts only, which doesn't move the focus out of the (by default docked) Undo History dialog).

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 12832.
Other node tool related commands (Alt+J, Maj+J and probably some others) also clear the undo history.
It seems that the node tool doesn't check if something is selected before applying the command.

Changed in inkscape:
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

Patch attached.
It adds some selection tests where needed.
I didn't find any regression so far, but... please test!

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
milestone: none → 0.49
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Patch tested on Windows XP, Inkscape trunk revision 12832.

tags: added: node-editing
jazzynico (jazzynico) wrote :

Fix committed revision 12848.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Also fixed in the 0.48.x branch, revision 10004.

Changed in inkscape:
milestone: 0.49 → 0.48.5
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers