Numbers in odg export have comma instead of dot

Bug #1249004 reported by Rb-henschel on 2013-11-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Kris

Bug Description

Start a new drawing.
Draw a spiral.
Save the file using .odg file format.

When this file is opened in a debug build in Apache OpenOffice it produces an error message. The reason are the lines
svg:stroke-width="0,000pt"
and
svg:stroke-opacity="100,000%"
in the file styles.xml

Replacing the comma with a dot fixes the problem. A comma is not a valid decimal delimiter in SVG.

I have used a German Inkscape 0.48 on a German Windows 7.

Rb-henschel (rb-henschel) wrote :
Kris (kris-degussem) wrote :

Do you still have the same problem with a compiled development version (aka trunk)?

Changed in inkscape:
importance: Undecided → Medium
tags: added: exporting odg
Kris (kris-degussem) wrote :

Confirmed in Inkscape 0.48.4. I should have fixed this in trunk...

Kris (kris-degussem) wrote :

(tests done with Belgian locale)

Rb-henschel (rb-henschel) wrote :

Hi Kris, I have download inkscape_r12742-201310291830.7z. With that version the export is correct.

Kris (kris-degussem) wrote :

Thanks for the update.

Changed in inkscape:
status: New → Fix Committed
assignee: nobody → Kris (kris-degussem)
milestone: none → 0.49
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers